Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por RahelCunha 31 Mai 2020 às 14:13
Membro Novato
Mensagens: 19
Reputação: 0
#55412
Boa tarde pessoal, tudo bem?

Primeiramente gostaria de agradecer muito a ajuda que obtive aqui semana passada do nobre colega osvaldomp. Por ser novo, acabei fechando o tópico sem o devido agradecimento. Agradeci no chat, mas acredito que não tenha visto.

Gostaria muito da ajuda de vocês com a planilha em anexo.
Utilizo a formula abaixo na celula “P9”. Para somar os itens únicos, ou seja, os valores que não se repetem na coluna “ITEM”(Coluna “B”)

SOMA(--(FREQÜÊNCIA(SE(Hist.S.Val!$F$3:$F$5300&""="";CORRESP(Hist.S.Val!$B$3:$B$5300;Hist.S.Val!$B$3:$B$5300;0));LIN(INDIRETO("1:"&LINS(Hist.S.Val!$B$3:$B$5300))))>0))

Porém, gostaria que ela somasse os itens que não se repetem e também apenas os valores da data atual, contida na célula “P4” e que também desconsiderasse dessa soma as linhas da coluna “CD_ENDERECO” que a primeira letra fosse “D”.

Por exemplo,

No dia 25/05 eu teria apenas 1 item sem data, pois apesar de a coluna “DT_VALIDADE” possuir 2 valores vazios, eles são valores iguais na coluna “ITEM”, então, seria considerado apenas 1 vez, e como a coluna “CD_ENDERECO” não tem nenhum valor que começa com a letra “D” não se aplica nenhum critério.

No dia 26/05 eu não teria nenhum item sem validade, pois apesar de na coluna “DT_VALIDADE” possuir 1 valor vazio e apesar de ele não se repetir na coluna “ITEM”, na coluna CD_ENDERECO” ele começa com a letra “D”, então não é considerado.

No dia 27/05 eu teria 1 item sem validade;
No dia 28/05 eu não teria nenhum item sem validade;
No dia 29/05 eu teria 1 item sem validade ];
E no dia 31/05 eu teria 4 itens sem validade.

Desde já muito obrigado.

Segue planilha em nexo.
Apenas usuários registrados podem ver ou baixar anexos.
Por babdallas 01 Jun 2020 às 07:56
Excel Expert
Mensagens: 2892
Reputação: 1256
#55422
Veja se é isso:

Código: Selecionar todos=SOMA(--(FREQÜÊNCIA(SE((Hist.S.Val!$F$4:$F$10000&""="")*(ESQUERDA(Hist.S.Val!$D$4:$D$10000;1)<>"D")*(Hist.S.Val!$A$4:$A$10000=$P$4);CORRESP(Hist.S.Val!$B$4:$B$10000;Hist.S.Val!$B$4:$B$10000;0));LIN(INDIRETO("1:"&LINS(Hist.S.Val!$B$4:$B$10000))))>0))
Apenas usuários registrados podem ver ou baixar anexos.
Por RahelCunha 01 Jun 2020 às 15:32
Membro Novato
Mensagens: 19
Reputação: 0
#55449
babdallas escreveu:Veja se é isso:

Código: Selecionar todos=SOMA(--(FREQÜÊNCIA(SE((Hist.S.Val!$F$4:$F$10000&""="")*(ESQUERDA(Hist.S.Val!$D$4:$D$10000;1)<>"D")*(Hist.S.Val!$A$4:$A$10000=$P$4);CORRESP(Hist.S.Val!$B$4:$B$10000;Hist.S.Val!$B$4:$B$10000;0));LIN(INDIRETO("1:"&LINS(Hist.S.Val!$B$4:$B$10000))))>0))


Grande babdallas , boa tarde!
Doutor, era exatamente isso. Simplesmente incrível. Muitissímo obrigado. Já não sabia mais o que fazer. Até aula particular realizei sem solução.
Deus lhe abençoe e multiplique esse maravilhoso conhecimento. Parabéns e mais uma vez obrigado. Não consigo enviar PM para contato.