Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Jeczei 13 Jan 2020 às 16:34
Membro 1 Estrela
Mensagens: 16
Reputação: 1
#51654
Pessoal, boa tarde
Agradeço a quem puder me ajudar com a solução para criar ranking seletivo a partir de um ranking geral de acordo com a natureza do investimento, conforme detalhes na planilha anexa.
Obrigado.
Abs
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 13 Jan 2020 às 20:46
Membro 5 Estrelas
Mensagens: 637
Reputação: 301
#51669
Fórmula matricial. Cole e confirme com Ctrl+Shift+Enter.
Código: Selecionar todos=SEERRO(ÍNDICE($J$9:$AM$9;;CORRESP(MAIOR(SE($J$7:$AM$7="Renda Fixa";$J$9:$AM$9);LIN(Z1));$J$9:$AM$9;0));"")

Copie para preencher a coluna.

Mude na fórmula o texto "Renda Fixa" para referência a uma célula com o critério desejado.

Good luck!
Por Jeczei 13 Jan 2020 às 22:05
Membro 1 Estrela
Mensagens: 16
Reputação: 1
#51671
Estevaoba, boa noite,
Muito obrigado pelo retorno, funcionou em parte, pois quando faço a associação do percentual (j9:m9) ao nome do investimento (j4:m4), na coincidência de valores, a referencia ao investimento fica errada.
Usei a fórmula:
=SEERRO(ÍNDICE($J$4:$AM$4;CORRESP(MAIOR(SE($J$7:$AM$7=$T$12;$J$9:$AM$9);LIN(A1));$J$9:$AM$9;0));"") + Ctrl+Shift+Enter
Abs
Por Jeczei 13 Jan 2020 às 23:46
Membro 1 Estrela
Mensagens: 16
Reputação: 1
#51672
Estevaoba,
Segue a planilha para deixar mais claro a dúvida/problema...
Obrigado mais uma vez
Abs
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por FelipeMGarcia 14 Jan 2020 às 12:05
Excel Expert
Mensagens: 3968
Reputação: 1728
#51681
Amigo,

Veja se o que fiz lhe ajuda, caso queira agradecer, clique na mãozinha.

Eu pintei em amarelo onde fiz as fórmulas.

Abs
Apenas usuários registrados podem ver ou baixar anexos.
Por Jeczei 14 Jan 2020 às 17:08
Membro 1 Estrela
Mensagens: 16
Reputação: 1
#51691
Felipe, boa tarde
Perfeito !
Muito obrigado pela ajuda !
Abs
Por Jeczei 16 Jan 2020 às 14:49
Membro 1 Estrela
Mensagens: 16
Reputação: 1
#51734
Felipe, boa tarde
Ainda sobre a sua ajuda, preciso adicionar mais uma 2a. condição, validando se o investimento está ativou ou inativo. É possível adicionar ?
Muito obrigado antecipadamente.
Abs