Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
#62414
Boas, tenho o seguinte ficheiro, que contem 2 tabelas.

Quero identificar o valor na primeira tabela, baseado na segunda tabela.

Para isso criei um código único para cada linha.

Problema: Nesse código único ele pega a quantidade da tabela 1, mas na tabela 2 essa quantidade(em alguns casos pode variar, ser maior ou menor), fazendo com que o código único seja diferente e não associando assim o identificador.



Ficheiro em anexo, mais explicado e com exemplo.



Obrigado!
Você não está autorizado a ver ou baixar esse anexo.
Editado pela última vez por AfonsoMira em 23 Fev 2021 às 09:14, em um total de 1 vez.
#62416
AfonsoMira, Bom Dia.

Usa desta forma

=SEERRO(ÍNDICE(TbIdentificadores!$A$2:$A$11;CORRESP(PROCV(D2;TbIdentificadores!$D$2:$D$11;1;0);TbIdentificadores!$D$2:$D$11;0));(ÍNDICE(TbIdentificadores!$A$2:$A$11;CORRESP((PROCV(D2;TbIdentificadores!$D$2:$D$11;1;1));TbIdentificadores!$D$2:$D$11;0))))

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
AfonsoMira agradeceu por isso
#62417
Salve, @AfonsoMira

Experimente esta matricial.
Código: Selecionar todos
=ÍNDICE(TbIdentificadores!A$2:A$11;CORRESP(MÍNIMO(ABS(D2-(TbIdentificadores!D$2:D$11)));ABS(D2-(TbIdentificadores!D$2:D$11));0))
AfonsoMira agradeceu por isso
#62418
@Deciog É exatamente isso, muito obrigado. :)
Deciog agradeceu por isso
#62419
@osvaldomp, A sua também funcionou.
Obrigado :)
osvaldomp agradeceu por isso
Ajuda sobre Formulario

Estou tendo problema no lançamento do formu[…]

Experimente: =SE(OU(CONT.VALORES(A2;D2;E2)<3;[…]

Criação de Conta Gratuita

Kledison, COnsegui pelo link que vc enviou Obriga[…]

DataAtual + NºSérie

Experimente: =TEXTO(HOJE();"AAA.MM.DD"[…]

Boa tarde, AfonsoMira Grato, por atender a minha[…]

Função PROCV com SE.ERRO

A opção encontra-se desativada por e[…]

Boa tarde Foxtri Serviria se fosse em VBA. E tem […]

Foi um prazer poder ajudar. :)