Assuntos relacionados a criação de medidas, fórmulas e funções DAX, relacionamentos etc
  • Avatar do usuário
#56655
Olá pessoal,
Preciso de uma grande ajuda de vocês.
Preciso colocar a fórmula abaixo que está em Excel e transformá-la em DAX.
Código: Selecionar todos
=SEERRO(
MÉDIASES($E$1:$E$16;$I$1:$I$16;"A";$F$1:$F$16;PROCV($B$2;$D$1:$I$16;3;FALSO));
SEERRO(
MÉDIASES($E$1:$E$16;$I$1:$I$16;"A";$G$1:$G$16;PROCV($B$2;$D$1:$I$16;3;FALSO);$H$1:$H$16;PROCV($B$2;$D$1:$I$16;4;FALSO));
MÉDIASES($E$1:$E$16;$I$1:$I$16;"B";$G$1:$G$16;PROCV($B$2;$D$1:$I$16;3;FALSO);$H$1:$H$16;PROCV($B$2;$D$1:$I$16;4;FALSO))))
Ela serve para calcular a média de [Velocidade] usando os critérios de filtro de [Categoria], [Grupo], [Tamanho], [Potência], conforme imagem da tabela abaixo.

Consegui filtrar a [Categoria], mas os demais critérios de filtro não consigo encontrar uma forma de fazer.
Ela tem que pegar o valor que está em [Descrição, Item], localizar na [Lista] e com base nos filtros de [Grupo], [Tamanho], [Potência] e [Categoria], ela calcula a média.

[Grupo], [Tamanho], [Potência] devem ser do mesmo grupo do item que está em [Descrição, Item].
Código: Selecionar todos
CALCULATE(
    AVERAGE(Velocidade]), 
    FILTER(
        ALL(Base),Base[Categoria] = "A")
Imagem

Obrigado!
#56675
Henrique,
Conforme conversamos via WhatsApp, segue medida para testes:
Código: Selecionar todos
Medida = 
VAR vCategoria = MAX(Tabela[Category])
VAR vGrupo = MAX( Tabela[Group] ) 
VAR vTamanho = MAX( Tabela[Size] )
VAR vPMT = MAX( Tabela[PMT] )


Return
    CALCULATE(
        AVERAGE( Tabela[Speed] ) ; 
        FILTER( 
            ALL( Tabela ); 
            Tabela[Size] = vTamanho &&
            Tabela[PMT] = vPMT &&
            Tabela[Group] = vGrupo &&
            Tabela[Category] = vCategoria )
    )
Imagino que no lugar do MAX das variáveis pode utilizar o SELECTEDVALUE.

Boa tarde! Precisava de um fórmula que con[…]

Do e-mail para o excel

https://support.microsoft.com/pt-br/office/importa[…]

Bom dia, preciso de uma ajuda dos mestres do Excel[…]

Copiar colunas em nova guia

... o cplicado...odigo acima enviado pelo cole[…]

Segue dados de Exemplo extraidos no SQL id_cliente[…]

Gente, muito obrigado!! Com a ajuda de voces cons[…]

DESLOC LARGURA

Olá Pessoal, Minha dúvida é […]

Copiar Aba e colar em nova aba

Estamos a disposição... Fico muito f[…]