Utilize essa sessão para criar tópicos relacionados a tabelas dinâmicas, formatações condicionais, subtotais, filtros, etc
  • Avatar do usuário
Por IgorARocha
#64555
Boa tarde. Eu tenho uma tabela com os meses nas colunas em que as células têm esta fórmula para somar os dados de várias folhas de acordo com uma certa condição:

=SOMARPRODUTO(SOMA.SE.S(INDIRETO("'"&Glossário!$A$2:$A$25&"'!"&"S6:S10");INDIRETO("'"&Glossário!$A$2:$A$25&"'!"&"P6:P10");$B3)))

No entanto quando arrasto a fórmula para a célula do lado esta não muda o mês (de S6:S10 para T6:T10). Existe alguma maneira de a fórmula atualizar automaticamente quando arrasto para a coluna do lado?
Agradeço desde já qualquer ajuda.
Avatar do usuário
Por CursoDeExcelGratis
#64565
boa noite,
a fórmula vai depender de onde vc vai colocar, pois vc poderia usar lin() e col() para montar uma referência dinâmica, pois do jeito que vc fez, como deixou entre aspas duplas realmente arrastar não vai alterar ele.

analise o resultado desta fórmula ao colocar ela na B8
=ENDEREÇO(LIN() -1;COL();4)
vai ver que fica o texto B7 e se arrastar ele vai atualizar corretamente.
Fórmulas SE

Olá, @Wieniawski . Aparentemente n&ati[…]

boa noite a todos, sou novato em uso de VBA, estou[…]

Prezados boa noite, gostaria de saber se e poss&ia[…]

data EMPOLAMENTO PEDIDO ocupação[…]

Rastreabilidade de Dados

Boa Tarde! Funcionamento atual: Ao inserir dad[…]

#vba nao roda no excel online Pessoal Tenho uma p[…]

Boa tarde, pessoal. Preciso de ajuda para uma mac[…]

Boa tarde pessoal! Eu tenho uma planilha que cont&[…]