Assuntos que não estiverem relacionados as categorias acima. Se não souber em qual categoria sua mensagem se encaixa, envie aqui.
  • Avatar do usuário
#67468
Olá pessoal!
Estou fazendo um trabalho e me deparei com um problema e gostaria de uma ajuda....
Estou calculando o tempo que demorou entre dois procedimentos(SLA 1) em dias e horas úteis, porém não consegui uma forma de calcular as horas úteis,

Recebimento das informação: 16/08/2021 10:03:00
Envio ao convênio: 17/08/2021 12:22:00
SLA1: Envio ao convênio - Recebimento da informação [ no formato dd/mm/aa hh:mm:ss]

Utilizei a seguinte fórmula: =SE([@[RECEBIMENTO DA INFORMAÇÃO]]="";"";SE([@[ENVIO AO CONVÊNIO]]="";$O$1-[@[RECEBIMENTO DA INFORMAÇÃO]];(DIATRABALHOTOTAL([@[RECEBIMENTO DA INFORMAÇÃO]];[@[ENVIO AO CONVÊNIO]])-MOD([@[RECEBIMENTO DA INFORMAÇÃO]];1)+MOD([@[ENVIO AO CONVÊNIO]];1))-VALOR("24:00")))
Porém a mesma não considera somente horas úteis, q seria o horário do expediente (9:00h às 18:00h)


Alguém consegue me ajudar? coloquei um anexo para melhora visualização.
Você não está autorizado a ver ou baixar esse anexo.
#67534
Não ficou claro como vc quer realmente calcular o tempo, por exemplo, recebeu a informação em 16/8/21 10:00, enviou em 17/8/21 10:00, vc quer calcular isso como 1d 0h 0min ou 0d 9h 0min? (24h - 15h não trabalhada)
Mesclar no VBA

@osvaldomp Sim eu lembro, instalei os dois e […]

Pessoal, boa tarde! Antes de postar aqui tentei d[…]

Boa Tarde! Se Possível, Em funç&atil[…]

Show de bola, você foi em cima do problema, […]

Dida, Bom Dia. Detalhe no anexo Confere se &eacu[…]

Tente colocar TRUE() na SWITC ...SWITCH ( TRUE(),[…]

Olá, @felipefaccini . Grato pelo retor[…]

[RESOLVIDO]VBA Crashando

Olá, @PedroRamirez . Ao abrir o seu […]