Assuntos que não estiverem relacionados as categorias acima. Se não souber em qual categoria sua mensagem se encaixa, envie aqui.
#61545
Bom-dia!

Numa pasta do servidor [ D:\Server\BemViver\Piscina\Armarios\DataOrigem ] é gravado de 15 em 15 minutos um ficheiro csv composto por 7 colunas [Sala] [Armario] [Utente] [Nome] [Saldo] [Data] [nDoc] e que é gerado automaticamente por um software de gestão. O nome deste ficheiro csv é atribuido pela seguinte regra [ DataZ_XYZ_20210115_131500.csv ] onde o grupo [ DataZ_XYZ_ ] é fixo. Apenas mudam os grupos Data e Hora a que o ficheiro é gravado. A hora não é rigorosa, dependendo do delay de gravação.

Numa pasta [ D:\Server\BemViver\Piscina\Armarios ] tenho um ficheiro [ Status.Armarios.xlsx ] que está ligado SEMPRE AO ÚLTIMO ficheiro csv gravado.
Por exemplo:
No Momento1 o ficheiro [ Status.Armarios.xlsx ] está ligado ao [ DataZ_XYZ_20210115_131500.csv ]
No Momento2 (15 minutos depois) o ficheiro [ Status.Armarios.xlsx ] deixa de estar ligado ao ficheiro [ DataZ_XYZ_20210115_131500.csv ] e passa a estar ligado ao ficheiro [ DataZ_XYZ_20210115_133025.csv ] entretanto gravado
No Momento3 (15 minutos depois do Momento2) o ficheiro [ Status.Armarios.xlsx ] deixa de estar ligado ao ficheiro [ DataZ_XYZ_20210115_133025.csv ] e passa a estar ligado ao ficheiro [ DataZ_XYZ_20210115_134510.csv ] e assim sucessivamente
O que pretendo é:
Atendendo a que, de 15 em 15 minutos é gravado e acrescentado um novo csv na pasta do servidor de acordo com a dita regra, como é que faço para que o ficheiro [ Status.Armarios.xlsx ] esteja sempre actualizado e ligado ao último ficheiro csv que foi inserido?
* No ficheiro csv, o nome da Folha/Sheet muda de acordo com o nome do ficheiro (mesmo nome).

Obrigado Jesus Santos

Veja se atende. Selecione B4:G7 | menu Pág[…]

Ajuda sobre Formulario

mano valeu muito, deu certo coloquei em todos as l[…]

DataAtual + NºSérie

Entendi. Obrigado novamente pela explicaç&a[…]

@Angra , o botão para marcar resolvido[…]

Quero comparar as colunas sim, que neste caso s&[…]

Achei a dúvida bem interessa mas acho que o[…]

Experimente: =SE(OU(CONT.VALORES(A2;D2;E2)<3;[…]

Criação de Conta Gratuita

Kledison, COnsegui pelo link que vc enviou Obriga[…]