Tópicos relacionados a códigos VBA, gravação de macros, etc.
Por Domingsp
#68501
Olá, na planilha anexada, a cada vez que aperto o botão CALCULAR, somo o número em B2 a um número da coluna C e o resultado sai numa textbox de um formulário.
Preciso que os resultados apareçam em sequência. Na primeira vez que apertar o botão aparecerá 12,11; na segunda vez, 23,10, embaixo de 12,11; na terceira, aparece 24,90 depois dos dois anteriores, até somar ao último número de C.
O que estou conseguindo é fazê-los aparecer um por um.
A célula A6 conta a linha de C que será somada.
Além disso, preciso que apareçam apenas duas casas decimais nos resultados. Tentei algumas formatações, mas não deu certo.
A figura exemplifica como os resultados devem aparecer, ao atingir o último número de C.
Desde já, obrigado.
EXEMPLO.xlsm
Imagem
Você não está autorizado a ver ou baixar esse anexo.
#68502
Olá, @Domingsp .

Sugestão: utilize ListBox com o método AddItem, no lugar da TextBox.
Domingsp agradeceu por isso
Buscar Dados em outra planilha

Fiz uma atualização mostrando o camp[…]

Boa tarde! Solicito a sua ajuda, de acordo com o […]

Controles ActiveX Excel Mac

Pessoal, seguinte: Meu sistema não roda no[…]

Olá, sou novo aqui no fórum, tenho u[…]

Boa tarde. Estou precisando automatizar uma planil[…]

Em J52 ~~~> =ÍNDICE(C10:C40;CORRES[…]

Salvar PDF sem substituir o arquivo

Boa tarde pessoal, Queria uma ajuda para fazer um[…]

Assiduidade

Bom dia a tod@s, tenho uma tabela no formato que s[…]