Tópicos relacionados a códigos VBA, gravação de macros, etc.
  • Avatar do usuário
#68437
Imagem

Boa noite

criei uma coleção com 100 linhas ( gerou com sucesso ) , no final do loop estou querendo descarregar todas de uma vez em um range específico , só estou conseguindo baixar semente uma ( colocando o número do index)

como faço para descarregar todas as linhas dessa Collection no final do loop ?

obrigado
#68443
Veja se ajuda
Código: Selecionar todos
Sub CollectionToArrayToSpreadSheet()
    Cells.ClearContents
    ' think of this collection as
    '   key     =   cell.row
    '   item    =   cell.value
    Dim dict As New Dictionary
    dict.Add Key:=1, Item:="value1"
    dict.Add Key:=2, Item:="value2"
    dict.Add Key:=3, Item:="value3"

    ' THIS WAY
    'Range("A1:A" & UBound(dict.Keys) + 1) = WorksheetFunction.Transpose(dict.Keys)
    'Range("B1:B" & UBound(dict.Items) + 1) = WorksheetFunction.Transpose(dict.Items)

    ' OR
    Range("A1").Resize(UBound(dict.Keys) + 1, 1) = WorksheetFunction.Transpose(dict.Keys)
    Range("B1").Resize(UBound(dict.Items) + 1, 1) = WorksheetFunction.Transpose(dict.Items)

End Sub
https://stackoverflow.com/questions/182 ... xcel-sheet
felipe2269 agradeceu por isso
#68450
obrigado pelo retorno

minha macro tá rodando normal até o momento de descarregar o resultado de uma vez na planilha1

dessa forma Não dar certo

Planilha1.range("v11" & ":am" & lUltcell).Value2 = clc

só consigo dessa forma : baixando só um índice por vez ( gostaria de baixar todos de uma vez 100 linha )
Planilha1.range("v11" & ":am" & lUltcell).Value2 = clc.item(1) - na célula v11 só baixou uma linha

Boa tarde! Solicito a sua ajuda, de acordo com o […]

Controles ActiveX Excel Mac

Pessoal, seguinte: Meu sistema não roda no[…]

Olá, sou novo aqui no fórum, tenho u[…]

Boa tarde. Estou precisando automatizar uma planil[…]

Em J52 ~~~> =ÍNDICE(C10:C40;CORRES[…]

Salvar PDF sem substituir o arquivo

Boa tarde pessoal, Queria uma ajuda para fazer um[…]

Assiduidade

Bom dia a tod@s, tenho uma tabela no formato que s[…]

Ficheiro mais atualizado