Tópicos relacionados a códigos VBA, gravação de macros, etc.
  • Avatar do usuário
#67471
To a horas aqui tentando resolver e não encontro o problema.
Carrego a lista na ComboBox, e quando escolho o usuário deveria carregar a senha do usuário na textbox
Porém quando faço a escolha do usuário vem o seguinte erro:

"Não foi possível obter a propriedade List. Argumento inválido."

Segue o código:

-------------------------------------------------------------------------------------
Private Sub UserForm_Initialize()

Dim CONT As Integer

On Error Resume Next

CONT = Range("Usuarios!A2").End(xlDown).Row
ComboBox1.RowSource = "Usuarios!A2:A" & CONT

End Sub
-------------------------------------------------------------------------------------
Private Sub ComboBox1_Change()

TextBox1 = ComboBox1.List(ComboBox1.ListIndex, 1)

End Sub
#67474
Anexa a planilha, por favor.
#67497
Tente assim:
Código: Selecionar todos
Dim xRg As Range

Private Sub ComboBox1_Change()
    Me.TextBox1.Text = Application.WorksheetFunction.VLookup(Me.ComboBox1.Value, xRg, 2, False)
End Sub

Private Sub UserForm_Initialize()
    Set xRg = Worksheets("Usuarios").Range("A2:B10")
    Me.ComboBox1.List = xRg.Columns(1).Value
End Sub
Fórmula para contagem

=SE(F18>=4;1;F18+1)

SOMAR PRODUTOS

Junqueira, desculpa a demora . obrigado. perfeito

Boa tarde. Com a ajuda de um membro do fór[…]

Gráfico de Cascata

Olá, Estou tentando montar um gráfi[…]

Laundip, algumas dicas, quando vai realizar tra[…]

Galera, boa noite! Estou em um enorme desafio ment[…]

Olá, Não sou expert mas se quiser mi[…]

Só um complemento, estava errada a segunda […]