Tópicos relacionados a códigos VBA, gravação de macros, etc.
  • Avatar do usuário
#65981
Olá a todos!
Estou precisando fazer uma busca usando o caracter coringa "*" e está dando erro na variável.
Tenho um campo onde se encontra a parte fixa da variável de busca.
1 - Gero a variável de busca antes de entrar no FIND: xCodResumoT = Cells(xLinAltL, "B").Value & "*"

2- Chamo o FIND e dá erro nesta variável
xCodResumoT = wsMemo.[vEtapasMemo].Find(xCodResumoT , lookat:=xlWhole)

Como fazer buscas no FIND usando caracteres coringa?
Editado pela última vez por BritoMarques em 26 Jul 2021 às 21:40, em um total de 1 vez.
#65984
Qual é o erro retornado ?

Se for 91 - A variável do objeto ou a variável do bloco "With" ... ~~~> é porque o valor da variável não existe no intervalo buscado.

Por favor, envia uma amostra das suas bases de dad[…]

Boa tarde! Criar uma formatação con[…]

Renato, A planilha em anexo para precisa digitar[…]

Exportação CSV

Quando faço a exportação de u[…]

Em C5: =SEERRO(SE(PROCV(B3;'Registro Pendencia'!A[…]

Macro Relatório Diário

Bom dia pessoal! Preciso de ajuda para elaborar um[…]

Olá, @brunoangelo . Sugestão, d[…]

Calculo horas power query

Boa noite, pessoal Tenho um problema que ainda n&[…]