Tópicos relacionados a códigos VBA, gravação de macros, etc.
  • Avatar do usuário
  • Avatar do usuário
Avatar do usuário
Por JCabral
#62591
Boa noite

Precisava de desenhar um layout de uma Timeline, conforme ficheiro anexo, com os seguintes dados:
MÊS ~~> De Janeiro a Dezembro
DIAS MÊS ~~> Dias de cada mês em formato dd/mm/aaaa
SEMANA~~> Número da semana, atendendo a que a primeira semana começa no primeiro dia de cada ano e que a segunda-feira é o primeiro dia de trabalho;
DIA/FERIADOS~~> Dias de cada mês - só o dia
DIA/SEM ~~> Dia da semana

A construção deste layout tem que ser dinâmico e deverá ser efetuado atendendo ao ano que está em SETTINGS("B2")

Gostaria ainda que fosse privilegiada a rapidez de escrita de dados na planilha, já que este está a ser o meu maior problema.

Em anexo está um exemplo do que pretendo, resultado final, mas apenas para dois meses....preciso para o ano todo.

Obrigado
Jorge Cabral
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por JCabral
#62640
Boa tarde Foxtri, muito obrigado

Serviria se fosse em VBA.
E tem um problema que é se o ano tiver 52 ou 54 semanas já não dá direito, será preciso acrescentar ou retirar colunas no final do ano.

Muito obrigado

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]