Tópicos relacionados a códigos VBA, gravação de macros, etc.
  • Avatar do usuário
Por Inovacao
#62541
Boa noite!!

Alguém sabe como fazer essa Macro funcionar, mesmo com a Planilha Bloqueada.
SENHA: 1234

Segue Planilha.

Obrigado!!
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Kledison
#62544
Ola,

uma sugestão é colocar essas duas linhas de código no modulo 1 do arquivo.

antes da linha do código que filtra
Código: Selecionar todos
Sheets("DRE").Unprotect "1234"
depois da linha de código que filtra
Código: Selecionar todos
Sheets("DRE").Protect "1234"
mesma coisa para a MACRO DESFILLTRAR,como na imagem abaixo.

Imagem
Por Inovacao
#62552
Boa tarde, Kledison!!


O Botão filtrar deu certo, mas o desfiltrar esta com erro.
Aparece a mensagem de FIM, DEPURADOR E ETC

Segue Planilha.

Obrigado!!
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
Por Kledison
#62558
@Inovacao ,

você não fez como está na imagem que postei acima, segue planilha com as alterações

Att
Você não está autorizado a ver ou baixar esse anexo.
Por Inovacao
#62560
Boa tarde, Kledison!!

Na verdade fiz sim, mas não sei se fiz da forma correta.
Me tira uma duvida, como faço para abrir o VBA e visualizar as fórmulas, pois aperto ALT+F11 mas não aparece os códigos.

Muito obrigado!!
Avatar do usuário
Por Kledison
#62564
@Inovacao ,

além da tecla de atalho mencionada por você, tem como acessar pela guia DESENVOLVEDOR, conforme GIF abaixo.

Imagem



Att
AfonsoMira agradeceu por isso
Por Inovacao
#62583
Boa tarde!!

Perfeito, deu certo a sua solução, já estou utilizando.

Mas por acaso, voce conheceria alguma solução somente com fórmulas?


Muito obrigado!!
Avatar do usuário
Por Kledison
#62586
[@Inovacao ,

com fórmulas eu não tentei, mas acredito que a melhor solução é por MACRO.

Att
Inovacao agradeceu por isso
Por Inovacao
#62816
Boa tarde, Kledison!!
Tudo bom?

Fera, voce consegue me ajudar com este código, se refere ao mesmo que voce fez para mim, e estou tentando replicar em outras planilhas idênticas aquela.

Sabe me explicar qual a diferença entre o primeiro e o segundo código?

Porque ao executar o primeiro código a planilha permanece bloqueada,.
Já ao executar o segundo código a planilha fica desbloqueada, e queria que ficasse bloqueada, quando eu executasse a função DESFILTRAR.

CÓDIGO 1

Sub FILTRAR2()
'
' FILTRAR2 Macro
'
Sheets("Mov_eMPRESA-Salvo").Unprotect "1234"
'
ActiveSheet.Range("$G$4:$AQ$630").AutoFilter Field:=36, Criteria1:= _
"Com Valores"

Sheets("Mov_eMPRESA-Salvo").Protect "1234"
End Sub


CÓDIGO 2

Sub DESFILTRAR2()
'
' DESFILTRAR2 Macro
'
Sheets("Mov_eMPRESA-Salvo").Unprotect "1234"
'
ActiveSheet.Range("$G$4:$AQ$630").AutoFilter Field:=36

Sheets("Mov_Orçamento-Salvo").Protect "1234"

ActiveWorkbook.Save
End Sub


Obrigado!!
EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]

Boa tarde!! Tenho uma planilha para calculo de ho[…]