Tópicos relacionados a códigos VBA, gravação de macros, etc.
  • Avatar do usuário
#66055
Prezados, boa noite

eu estou utilizando o código abaixo, quando o produto faz parte da lista, tudo ok, o problema é tentar localizar um produto que não faz parte da lista, aparece um erro

a variavel do objeto ou a variavel do bloco with não foi definida

e quando eu abro o editor de código do vba, a linha
Código: Selecionar todos
Range("C3:C10").Find(PROCURAR).Select
fica grifada de amarelo e o código para de rodar.

tem como alterar isso. por exemplo colocar uma condição onde se não achar o texto procurado o vba exibir uma mensagem dizendo, o texto tal... não foi localizado na lista, se o texto for localizado então o vba realiza outra coisa, tipo uma condição IF

eu estou anexando a planilha para facilitar o entendimento, desde já agradeço pela atenção de todos.

código utilizado na planilha
Código: Selecionar todos
Sub LOCALIZAR()

Dim PROCURAR

PROCURAR = InputBox("QUAL O PRODUTO A SER LOCALIZADO")

Range("C3:C10").Find(PROCURAR).Select

End Sub
Você não está autorizado a ver ou baixar esse anexo.
#66062
Bom dia
Veja se desta forma serve.

Sub LOCALIZAR()
Dim PROCURAR
Dim Rng As Range
PROCURAR = InputBox("QUAL O PRODUTO A SER LOCALIZADO")
With Range("C3:C10")
Set Rng = .Find(PROCURAR, LookIn:=xlValues)
If Not (Rng Is Nothing) Then
Rng.Select
Else
MsgBox "Item não Encontrado", vbInformation, "Atenção"
End If
End With
End Sub

Até
Foxtri

Boa tarde! Criar uma formatação con[…]

Renato, A planilha em anexo para precisa digitar[…]

Exportação CSV

Quando faço a exportação de u[…]

Em C5: =SEERRO(SE(PROCV(B3;'Registro Pendencia'!A[…]

Macro Relatório Diário

Bom dia pessoal! Preciso de ajuda para elaborar um[…]

Olá, @brunoangelo . Sugestão, d[…]

Calculo horas power query

Boa noite, pessoal Tenho um problema que ainda n&[…]

RESOLVIDO!!!