Pesquisa resultou em 2514 ocorrências

 Voltar para a pesquisa avançada

Re: TIRAR CONTAGEM DO ZERO

 por osvaldomp ¦  13 Jun 2021 às 16:04 ¦  Fórum: Fórmulas e Funções ¦  Tópico: TIRAR CONTAGEM DO ZERO ¦  Respostas: 9 ¦  Exibições: 129

O erro é originado na fórmula da coluna M. Por exemplo, em M95 a fórmula busca a sexta maior pontuação, porém só há cinco pontuações (cinco nomes/jogos/acertos), por isso a fórmula retorna erro que afeta as fórmulas em B95 e H95. Para contornar coloque um tratamento de erro em M90 ~~~> =SEERRO(MAIOR...

Re: TIRAR CONTAGEM DO ZERO

 por osvaldomp ¦  13 Jun 2021 às 09:58 ¦  Fórum: Fórmulas e Funções ¦  Tópico: TIRAR CONTAGEM DO ZERO ¦  Respostas: 9 ¦  Exibições: 129

Salve, @Jerys . Segue uma solução mais simples pois faz a contagem direta dos acertos (não utiliza a tabela existente na Planilha2). Cole uma cópia da fórmula abaixo em L6 da Planilha1 e aplique duplo clique no canto direito inferior daquela célula para estender a fórmula pela coluna. =SE(CONT.VALOR...

Re: TIRAR CONTAGEM DO ZERO

 por osvaldomp ¦  12 Jun 2021 às 19:15 ¦  Fórum: Fórmulas e Funções ¦  Tópico: TIRAR CONTAGEM DO ZERO ¦  Respostas: 9 ¦  Exibições: 129

Entendi. :) Veja se assim resolve: desfaça a alteração que passei antes, ou seja, coloque o zero de volta no lugar do "-" e troque a fórmula que está em L6 por essa abaixo que não conta os zeros. =SOMARPRODUTO(CONT.SE(B6:K6;Planilha2!C$3:C$152)*(Planilha2!C$3:C$152>0)) ~~~> não é necessário inseri-l...

Re: TIRAR CONTAGEM DO ZERO

 por osvaldomp ¦  12 Jun 2021 às 15:47 ¦  Fórum: Fórmulas e Funções ¦  Tópico: TIRAR CONTAGEM DO ZERO ¦  Respostas: 9 ¦  Exibições: 129

No final da fórmula que está em C3 substitua o zero por "-" (sinal de menos entre aspas duplas)

Re: Excluir linhas com critério

 por osvaldomp ¦  12 Jun 2021 às 10:34 ¦  Fórum: Excel Básico ¦  Tópico: Excluir linhas com critério ¦  Respostas: 1 ¦  Exibições: 24

solução manua l 1. selecione qualquer célula do intervalo A1:O1 2. menu Dados | Filtro 3. clique na setinha de cada uma das colunas C a I, demarque Selecionar Tudo e marque Vazias , OK 4. exclua as linhas visíveis, remova o Filtro solução via macro Sub ExcluiLinhasVazias() Dim k As Long On Error Re...

Re: Macro para duplicar linhas de acordo com critérios

 por osvaldomp ¦  11 Jun 2021 às 20:56 ¦  Fórum: Macros e VBA ¦  Tópico: Macro para duplicar linhas de acordo com critérios ¦  Respostas: 1 ¦  Exibições: 15

Olá, @joaopedromoura . Eu tentei seguir o seu código mas confesso que não consegui. Eu me proponho a elaborar um novo código que atenda a sua demanda, pois entendo que é mais fácil do que remendar um código existente. Se for de seu interesse, então disponibilize um arquivo que contenha somente as pl...

Re: Somar e mesclar ao mesmo tempo

 por osvaldomp ¦  11 Jun 2021 às 19:51 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Somar e mesclar ao mesmo tempo ¦  Respostas: 1 ¦  Exibições: 13

Olá, @Feberlim . Se você quiser experimentar uma solução via macro, seguem duas opções. A primeira mescla A1:A4, seguindo o seu exemplo . A segunda mescla as células selecionadas manualmente, ou seja, selecione manualmente células adjacentes (aceita múltiplas linhas e ou múltiplas colunas) e rode a ...

Re: Macro Copiar / Formula

 por osvaldomp ¦  11 Jun 2021 às 19:08 ¦  Fórum: Macros e VBA ¦  Tópico: Macro Copiar / Formula ¦  Respostas: 5 ¦  Exibições: 59

Salve, @CAMILOALVES .

Que bom que você resolveu a sua demanda. :)

God bless you too! ;)

Re: Macro Copiar / Formula

 por osvaldomp ¦  11 Jun 2021 às 14:00 ¦  Fórum: Macros e VBA ¦  Tópico: Macro Copiar / Formula ¦  Respostas: 5 ¦  Exibições: 59

... porém a referida macro (CopiaColaFórmulasPR) não está atendendo ao proposto, sendo assim, se possível, peço analisar o que há de errado com ela ... Nada de errado com ela, o erro é tentar aproveitá-la, pois como comentei antes, ela não pertence a este jogo. Instale uma cópia do código baixo no ...

Taxa Arredondada (em K17) ~~~> =ARRED(E17*I17;2)

Valor Líquido ~~~> =E17-K17

ou

Valor Líquido ~~~> =E17-ARRED(E17*I17;2)

Re: Extrair Textos de duas StringS [BEGIN] [END]

 por osvaldomp ¦  10 Jun 2021 às 21:52 ¦  Fórum: Macros e VBA ¦  Tópico: Extrair Textos de duas StringS [BEGIN] [END] ¦  Respostas: 7 ¦  Exibições: 61

Este código abaixo funciona para os dois exemplos que você forneceu até agora. Se houver mais variações que o código não reconheça então informe TODAS as variações de uma vez. Sub ExtraiParteTexto() Dim K As Long, x As Long, m As Long rstt: For K = 1 To UBound(Split([A1], "[BEGIN]")) x = InStr(K + m...

Re: Extrair Textos de duas StringS [BEGIN] [END]

 por osvaldomp ¦  10 Jun 2021 às 19:46 ¦  Fórum: Macros e VBA ¦  Tópico: Extrair Textos de duas StringS [BEGIN] [END] ¦  Respostas: 7 ¦  Exibições: 61

Veja o arquivo anexado, com o código que passei.

Re: Deslocar a célula para direita, após fechar o arquivo deslocar para baixo

 por osvaldomp ¦  10 Jun 2021 às 14:32 ¦  Fórum: Macros e VBA ¦  Tópico: Deslocar a célula para direita, após fechar o arquivo deslocar para baixo ¦  Respostas: 2 ¦  Exibições: 29

Olá, @GENECI . Cole uma cópia dos códigos abaixo no módulo de EstaPastaDeTrabalho . Após, salve, feche e reabra o arquivo para testar. Private Sub Workbook_Activate() Application.MoveAfterReturn = True Application.MoveAfterReturnDirection = xlToRight End Sub Private Sub Workbook_Deactivate() Applica...

Re: Macro Copiar / Formula

 por osvaldomp ¦  10 Jun 2021 às 14:15 ¦  Fórum: Macros e VBA ¦  Tópico: Macro Copiar / Formula ¦  Respostas: 5 ¦  Exibições: 59

Salve, @CAMILOALVES . Me parece que você quer copiar as fórmulas de Q7 e S7 da planilha Registro e colar na última linha da própria planilha, que foi recém preenchida pelo código. É isso? A propósito, na fórmula em Q7 ~~~> =SE(B7="";"";SE(E(L7="";M7="";N7="");"SIM";SE(OU(L7<>"";M7<>"";N7<>"");"NÃO")...

Re: Ajuda - Como calcular horas, com números inteiros e outras horas.

 por osvaldomp ¦  10 Jun 2021 às 12:17 ¦  Fórum: Macros e VBA ¦  Tópico: Ajuda - Como calcular horas, com números inteiros e outras horas. ¦  Respostas: 7 ¦  Exibições: 36

Olá, @georgedo .

Que bom que ajudou.

Grato pelas palavras. God bless you too.

Re: Ajuda - Como calcular horas, com números inteiros e outras horas.

 por osvaldomp ¦  10 Jun 2021 às 11:41 ¦  Fórum: Macros e VBA ¦  Tópico: Ajuda - Como calcular horas, com números inteiros e outras horas. ¦  Respostas: 7 ¦  Exibições: 36

Veja se ajuda. 1. remova ou desative os códigos Private Sub boxhors_Change() e Private Sub boxhors_Exit() 2. no código Private Sub NovAlarm () acrescente a linha em vermelho conforme abaixo End If If boxhors.Value <> "" Then TextBox11.Value = boxhors.Value * boxdia.Value End Sub 3. insira o código a...

Re: Extrair Textos de duas StringS [BEGIN] [END]

 por osvaldomp ¦  10 Jun 2021 às 10:37 ¦  Fórum: Macros e VBA ¦  Tópico: Extrair Textos de duas StringS [BEGIN] [END] ¦  Respostas: 7 ¦  Exibições: 61

Experimente: Sub ExtraiParteTexto() Dim K As Long, x As Long, m As Long For K = 1 To UBound(Split([A1], "[BEGIN]")) x = InStr(K + m, [A1], "[BEGIN]") m = InStr(K + m, [A1], "[END]") Cells(Rows.Count, 5).End(3)(2) = Mid([A1], x + 7, m - x - 7) Next K End Sub # curiosidade: este comando que você posto...

JonasSilva escreveu: 09 Jun 2021 às 23:13 ... QUANTAS CÉLULAS ESTÃO COLORIDAS DE PRETO ... ~~~> as células são coloridas manualmente ou via Formatação Condicional ? Qual é o critério utilizado para colorir as células ?

... EM UMA DETERMINADA COLUNA ... ~~~> em qual coluna ?

Re: SOMAR VALORES POR MÉDICO/CONVÊNIO

 por osvaldomp ¦  09 Jun 2021 às 20:28 ¦  Fórum: Fórmulas e Funções ¦  Tópico: SOMAR VALORES POR MÉDICO/CONVÊNIO ¦  Respostas: 3 ¦  Exibições: 37

#
Segue uma alternativa. Em B2 da planilha APURA e arraste para baixo.

Código: Selecionar todos
=ÍNDICE('668'!E$5:E$161;MENOR(SE('668'!B$5:B$161="Total Convênio";LIN(B$5:B$161)-4);LIN(A1)))

Re: Ajuda - Como calcular horas, com números inteiros e outras horas.

 por osvaldomp ¦  09 Jun 2021 às 19:20 ¦  Fórum: Macros e VBA ¦  Tópico: Ajuda - Como calcular horas, com números inteiros e outras horas. ¦  Respostas: 7 ¦  Exibições: 36

[quote=osvaldomp post_id=65059 time=1623259091 user_id=6908 Sugestão: disponibilize diretamente aqui no fórum uma amostra do seu arquivo Excel com alguns exemplos e com os resultados desejados. . [/quote] # Informe com exatidão em quais campos do Form você tem problema. Exemplo: o usuário irá preenc...

  • 1
  • 2
  • 3
  • 4
  • 5
  • 126
TIRAR CONTAGEM DO ZERO

Bingo kkk... muito obrigado pela ajuda ...ficou 1[…]

Pode anexar seu pbix e/ou uma amostra dos seus dad[…]

Boa tarde! Gostaria de uma Help do grupo, uma fun[…]

Somatório de letras e ano

Caro Foxtri, Desculpe, fui no gerenciamento nome[…]

Calcular saldo acumulado

Ola tudo bem? nao encontrei o anexo

Veja o anexo e faça as adaptaç&otild[…]

EDITAR CÓDIGO

Pessoal, boa noite!! Por favor preciso de uma ajud[…]

Excluir linhas com critério

solução manua l 1. selecione qu[…]