Pesquisa resultou em 1949 ocorrências

 Voltar para a pesquisa avançada

Re: SomaSe Tunado

 por osvaldomp ¦  30 Nov 2020 às 10:00 ¦  Fórum: Macros e VBA ¦  Tópico: SomaSe Tunado ¦  Respostas: 1 ¦  Exibições: 19

Em D9

Código: Selecionar todos
=SOMARPRODUTO((MOD(COL(L9:BZ9);6)=0)*(M9:CA9>0);(L9:BZ9))

Em F9
Código: Selecionar todos
=SOMARPRODUTO((MOD(COL(L9:BZ9);6)=0)*(M9:CA9="");(L9:BZ9))

Em H9
Código: Selecionar todos
=SOMARPRODUTO((MOD(COL(L9:BZ9);6)=0)*(O9:CC9="SIM");(L9:BZ9))

obs. você colocou 390,00 em D11, mas o correto é 520,00

Re: Calcular DATA

 por osvaldomp ¦  29 Nov 2020 às 16:27 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Calcular DATA ¦  Respostas: 4 ¦  Exibições: 45

Experimente esta.

Código: Selecionar todos
=SE(DIA(H4)>E5;FIMMÊS(H4;0)+10;H4-DIA(H4)+10+10*(E(DIA(H4)>=C$4;DIA(H4)<=E$4))+20*(E(DIA(H4)>=C$5;DIA(H4)<=E$5)))

obs. se o mês da entrega da NF for fevereiro e o dia for maior que 25, então a fórmula retornará 1 ou 2/março.

Re: VINCULAÇÃO DE DADOS VIA LISTBOX

 por osvaldomp ¦  27 Nov 2020 às 20:02 ¦  Fórum: Excel Básico ¦  Tópico: VINCULAÇÃO DE DADOS VIA LISTBOX ¦  Respostas: 1 ¦  Exibições: 21

Segue uma ideia, veja se aproveita. 1. elabore uma tabela ocupando duas colunas, na coluna da esquerda coloque a lista dos produtos e na da direita os respectivos valores 2. aplique Validação de Dados na célula, ou no intervalo, que deseja inserir o nome do produto e utilize na Validação a lista de ...

Re: Contar Células Coloridas pela Formatação Condicional

 por osvaldomp ¦  25 Nov 2020 às 12:11 ¦  Fórum: Macros e VBA ¦  Tópico: Contar Células Coloridas pela Formatação Condicional ¦  Respostas: 2 ¦  Exibições: 50

Preciso da ajuda de alguém que conheça bem sobre VBA , :?: :?: :?: Considerando o primeiro arquivo disponibilizado no seu post: Plan1 ~~~> em A6 não está aplicada a Formatação Condicional e a cor em D6 é diferente de todas as cores aplicadas na Formatação Condicional na coluna A; corrigidos esses d...

Re: Ajuda com validação de dados.

 por osvaldomp ¦  25 Nov 2020 às 08:29 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Ajuda com validação de dados. ¦  Respostas: 2 ¦  Exibições: 26

Pesquise ~~~> excel validação de dados condicional ou excel validação de dados dependente Veja algumas dicas no link abaixo. https://www.google.com/search?ei=HD--X-PTIPrH5OUPptKq6AE&q=excel+valida%C3%A7%C3%A3o+de+dados+condicional&oq=excel+valida%C3%A7%C3%A3o+de+dados+condicional&gs_lcp=CgZwc3ktYWIQ...

Re: Associar valor de uma coluna a todos de outra coluna

 por osvaldomp ¦  24 Nov 2020 às 11:57 ¦  Fórum: Excel Básico ¦  Tópico: Associar valor de uma coluna a todos de outra coluna ¦  Respostas: 9 ¦  Exibições: 80

Sub ReplicaDadosV2() Dim m As Long, k As Long With Sheets("Modelos") .[D:J] = "" For m = 2 To .Cells(Rows.Count, 1).End(3).Row For k = 2 To Sheets("Opcionais").Cells(Rows.Count, 1).End(3).Row .Cells(Rows.Count, 4).End(3)(2) = .Cells(m, 1) .Cells(Rows.Count, 5).End(3)(2).Resize(, 6) = Sheets("Opcion...

Re: Associar valor de uma coluna a todos de outra coluna

 por osvaldomp ¦  24 Nov 2020 às 10:02 ¦  Fórum: Excel Básico ¦  Tópico: Associar valor de uma coluna a todos de outra coluna ¦  Respostas: 9 ¦  Exibições: 80

Para a primeira linha o resultado desejado seria esse abaixo, nas colunas D:J ?

#########D##############E#######F############G############H##########I###########J#######
2PU91DLNGK04A0D0#####NN01#####E#####Airbag passageiro#####NO#####180,26695#####199,19

Re: Associar valor de uma coluna a todos de outra coluna

 por osvaldomp ¦  24 Nov 2020 às 08:37 ¦  Fórum: Excel Básico ¦  Tópico: Associar valor de uma coluna a todos de outra coluna ¦  Respostas: 9 ¦  Exibições: 80

Experimente o código abaixo no lugar do anterior. O resultado será lançado pelo código nas colunas D:E de Modelos. Sub ReplicaDados() Dim m As Long, k As Long With Sheets("Modelos") .[D:E] = "" For m = 2 To .Cells(Rows.Count, 1).End(3).Row For k = 2 To Sheets("Opcionais").Cells(Rows.Count, 1).End(3)...

Re: Formulas estranhas rsrs

 por osvaldomp ¦  23 Nov 2020 às 20:17 ¦  Fórum: Macros e VBA ¦  Tópico: Formulas estranhas rsrs ¦  Respostas: 1 ¦  Exibições: 17

Seguem 3 chutes, apenas suposições, pois eu não entendi o que você quer. Se não for isso então disponibilize o seu arquivo Excel contendo o que você quer. Sub TesteV1() Range("J2").FormulaLocal = "=SE(E2=""diária"";A2*G2*I2+I2*(F2+H2)/2;A2*I2)" End Sub Sub TesteV2() Range("J2").Resize(9).FormulaLoca...

Re: Associar valor de uma coluna a todos de outra coluna

 por osvaldomp ¦  23 Nov 2020 às 11:30 ¦  Fórum: Excel Básico ¦  Tópico: Associar valor de uma coluna a todos de outra coluna ¦  Respostas: 9 ¦  Exibições: 80

Disponibilize uma planilha com 3 ou 4 exemplos do resultado desejado.

Re: Inserir formula como texto

 por osvaldomp ¦  23 Nov 2020 às 10:46 ¦  Fórum: Macros e VBA ¦  Tópico: Inserir formula como texto ¦  Respostas: 2 ¦  Exibições: 27

Experimente:

Código: Selecionar todos
Range("J6").FormulaLocal = "=SE(E5=""diária"";A5*G5*I5+I5*(F5+H5)/2;A5*I5)"

Re: Associar valor de uma coluna a todos de outra coluna

 por osvaldomp ¦  23 Nov 2020 às 09:45 ¦  Fórum: Excel Básico ¦  Tópico: Associar valor de uma coluna a todos de outra coluna ¦  Respostas: 9 ¦  Exibições: 80

Experimente. O resultado será lançado pelo código na coluna D de Modelos. Sub ConcatenaDados() Dim m As Long, k As Long With Sheets("Modelos") For m = 2 To .Cells(Rows.Count, 1).End(3).Row For k = 2 To Sheets("Opcionais").Cells(Rows.Count, 1).End(3).Row .Cells(Rows.Count, 4).End(3)(2) = .Cells(m, 1)...

Re: Data automática

 por osvaldomp ¦  23 Nov 2020 às 09:21 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Data automática ¦  Respostas: 3 ¦  Exibições: 51

Olá, Teresa. Você pode utilizar a função HOJE() e aí todas as células com essa função inserida em datas passadas serão atualizadas para a data do dia. No entanto, se você não quer que as datas inseridas anteriormente sejam atualizadas então instale uma cópia do código abaixo no módulo de EstaPastaDe...

Olá, Sérgio. Talvez o comando abaixo não seja a causa do problema mas me parece que ele está incorreto, pois está duplicado o teste de caixa_dtfimproc . If caixa_dtfimproc.Text <> "" And caixa_ dtfimproc .Text<> "" Then Deveria ser ~~~> If caixa_dtfimproc.Text <> "" And caixa_ dtiniproc .Text <> "" ...

Re: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia.

 por osvaldomp ¦  22 Nov 2020 às 21:24 ¦  Fórum: Macros e VBA ¦  Tópico: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia. ¦  Respostas: 9 ¦  Exibições: 30

Insere fórmulas em O:P.

Código: Selecionar todos
Sub InsereFórmulaV2()
 Dim k As Long
  For k = 6 To Cells(Rows.Count, 1).End(3).Row Step 4
   Cells(k, 15).FormulaR1C1 = "=SUM(RC[-11]:R[3]C[-11])/4/1000"
   Cells(k, 16).FormulaR1C1 = "=SUM(RC[-10]:R[3]C[-10])/4/1000"
  Next k
End Sub

Re: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia.

 por osvaldomp ¦  22 Nov 2020 às 21:03 ¦  Fórum: Macros e VBA ¦  Tópico: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia. ¦  Respostas: 9 ¦  Exibições: 30

... conforme anexo, aplicar a mesma formula so que na coluna 4 e 6 e os resultados mostrar na coluna 15 e 16 A planilha anexada não ajuda a entender o que você quer. Você quer aplicar a fórmula em uma célula mas quer o resultado em outra célula ... isso não faz sentido. Explique com clareza. Dispon...

Re: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia.

 por osvaldomp ¦  22 Nov 2020 às 20:37 ¦  Fórum: Macros e VBA ¦  Tópico: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia. ¦  Respostas: 9 ¦  Exibições: 30

... conforme anexo, aplicar a mesma formula so que na coluna 4 e 6 e os resultados mostrar na coluna 15 e 16 A planilha anexada não ajuda a entender o que você quer. Você quer aplicar a fórmula em uma célula mas quer o resultado em outra célula ... isso não faz sentido. Explique com clareza. Dispon...

Re: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia.

 por osvaldomp ¦  22 Nov 2020 às 19:53 ¦  Fórum: Macros e VBA ¦  Tópico: Aplicar a mesma fórmula de 4 em 4 linhas até linha A ficar vazia. ¦  Respostas: 9 ¦  Exibições: 30

Experimente:

Código: Selecionar todos
Sub InsereFórmula()
 Dim k As Long
  For k = 6 To Cells(Rows.Count, 1).End(3).Row Step 4
   Cells(k, 4).Resize(, 2).FormulaR1C1 = "=SUM(RC[-2]:R[3]C[-2])/4/1000"
  Next k
End Sub

Re: Erro no método Find

 por osvaldomp ¦  22 Nov 2020 às 09:21 ¦  Fórum: Macros e VBA ¦  Tópico: Erro no método Find ¦  Respostas: 2 ¦  Exibições: 41

Na execução essa macro apresenta Erro em tempo de execuçao '91': O erro ocorre se o número de C não for encontrado em F. Experimente o código abaixo vinculado diretamente ao botão, não é necessário um segundo código. Private Sub CommandButton1_Click() With Range("D2:D" & Cells(Rows.Count, 6).End(3)...

Re: Calcular DATA

 por osvaldomp ¦  20 Nov 2020 às 16:57 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Calcular DATA ¦  Respostas: 4 ¦  Exibições: 45

Experimente.

Código: Selecionar todos
=H4+10+10*(E(DIA(H4)>=C$4;DIA(H4)<=E$4))+20*(E(DIA(H4)>=C$5;DIA(H4)<=E$5))

  • 1
  • 2
  • 3
  • 4
  • 5
  • 98

Leonardo1234, Boa Tarde Para a versão Exce[…]

Mediana com condicional

Tente: =MED(SE(Atendimentos_TOTAL!G:G="8_2020[…]

Bom dia, pessoal. Alguém sabe dizer se exi[…]

SomaSe Tunado

Em D9 =SOMARPRODUTO((MOD(COL(L9:BZ9);6)=0)*(M9:C[…]

Caros, boa noite! Estou com um probleminha para r[…]

Mensagem de erro no VBA Excel

Boa tarde pessoal, nesse meu programa sobre montag[…]

Calcular DATA

Agora deu certo!!! Muito obrigado.

Auto numeração

Boa tarde, É possível criar uma aut[…]