Pesquisa resultou em 1836 ocorrências

Voltar à pesquisa avançada

Re: Excel reconhecer o nome do mês/ano como data

por osvaldomp ¦ 17 Set 2020 às 15:39 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Excel reconhecer o nome do mês/ano como data ¦ Respostas: 2 ¦ Exibições: 17

RodrigoLRS escreveu:de uma data 20/03/2020 ~~~> formate a célula: Personalizado | mmmm/aaaa
assim a célula irá manter a data e exibirá março/2020 sem utilizar fórmulas

Re: CALCULAR QUANTIDADE DE DIAS DE ATESTADO NO MES

por osvaldomp ¦ 16 Set 2020 às 09:41 ¦ Fórum: Linguagem DAX/Modelagem ¦ Tópico: CALCULAR QUANTIDADE DE DIAS DE ATESTADO NO MES ¦ Respostas: 2 ¦ Exibições: 18

Em F1 coloque 01/07/2020, que corresponde a MÊS FILTRADO Cole uma cópia da fórmula abaixo em C2 e arraste para baixo. =MÁXIMO(0;1+MÍNIMO(B2;FIMMÊS(F$1;0))-MÁXIMO(A2;F$1)) obs. o resultado correto para o seu terceiro exemplo é 31, e não 30 como você colocou, portanto o resultado final correto é 50 di...

Instale uma cópia do código abaixo no módulo da Planilha1 (para acessar o módulo clique com o direito na guia daquela planilha e escolha " Exibir Código ") Private Sub Worksheet_Change(ByVal Target As Range) Dim c As Range If Target.Address <> "$C$6" And Target.Address <> "$...

Sim, é assim que funciona por fórmulas, como você pediu.
Agora, se você quiser alterar o número e ou o texto na Planilha1 e manter o resultado anterior na Planilha2 então a solução deverá ser via macro.

Experimente uma cópia da fórmula abaixo em B1 da Planilha2 e arraste para baixo.

Código: Selecionar todos=SE(A1=Planilha1!A$2;Planilha1!B$2;"")

Confesso que não compreendi com 100% de clareza ... Pesquise sobre a função SOMARPRODUTO(). Para acompanhar cada etapa da execução da fórmula selecione a célula que contém a fórmula / menu Fórmulas / Avaliar Fórmula. ... é mandatório que as matrizes das tabelas 01 e 02 sejam do mesmo tamanho, ... A...

Experimente:

Código: Selecionar todos=SE(CONT.SE(J$4:R$12;F4)=0;"";ÍNDICE(J$3:R$3;SOMARPRODUTO(COL(A$4:I$12)*(J$4:R$12=F4))))

Se você utiliza XL 2019 ou MS 365, experimente a fórmula abaixo. Se não, me parece que uma UDF seria uma boa solução.

Código: Selecionar todos=UNIRTEXTO("; ";VERDADEIRO;D6:D20)

Re: Ajuda com conversão de medidas

por osvaldomp ¦ 07 Set 2020 às 20:40 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Ajuda com conversão de medidas ¦ Respostas: 4 ¦ Exibições: 36

Coloque uma cópia da fórmula abaixo em G5 e arraste até G20.

Código: Selecionar todos=F5/2,39


Ou, se você quiser que a fórmula retorne vazio em lugar de zero se as células em F5:F20 estiverem vazias, então utilize a fórmula abaixo.
Código: Selecionar todos=SE(F5="";"";F5/2,39)

Re: Todo o conteúdo numa única célula após o ENTER separar.  [resolvido]

por osvaldomp ¦ 07 Set 2020 às 17:45 ¦ Fórum: Macros e VBA ¦ Tópico: Todo o conteúdo numa única célula após o ENTER separar. ¦ Respostas: 1 ¦ Exibições: 13

Olá, Geneci. Experimente uma cópia do código abaixo no módulo da planilha. Private Sub Worksheet_Change(ByVal Target As Range) If Target.Column = 1 And Target.Value <> "" Then Target.TextToColumns DataType:=xlDelimited, Other:=True, OtherChar:=";" End Sub

Re: Ajuda com conversão de medidas

por osvaldomp ¦ 07 Set 2020 às 17:29 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Ajuda com conversão de medidas ¦ Respostas: 4 ¦ Exibições: 36

A1 = 125

A fórmula abaixo em qualquer célula vazia irá retornar ~~~> 52,30125523

Código: Selecionar todos=A1/2,39

Re: Retirar todos os espaços  [resolvido]

por osvaldomp ¦ 07 Set 2020 às 14:39 ¦ Fórum: Macros e VBA ¦ Tópico: Retirar todos os espaços ¦ Respostas: 2 ¦ Exibições: 20

Utiliize Replace ;)

Re: Fazer uma seleção partir de variáveis  [resolvido]

por osvaldomp ¦ 07 Set 2020 às 09:32 ¦ Fórum: Macros e VBA ¦ Tópico: Fazer uma seleção partir de variáveis ¦ Respostas: 1 ¦ Exibições: 14

Experimente:

Código: Selecionar todosRange("A" & L & ":C" & J).Select

Re: A Função Len não está retornando o resultado  [resolvido]

por osvaldomp ¦ 06 Set 2020 às 14:24 ¦ Fórum: Macros e VBA ¦ Tópico: A Função Len não está retornando o resultado ¦ Respostas: 3 ¦ Exibições: 31

BrunoLuiel escreveu: Do While Len("A" & NF_inicia) <> 14

Se você quer comparar o número de caracteres contidos na célula A & NF_inicia então utilize
Do While Len(Range("A" & NF_inicia)) <> 14


Testaí:

Código: Selecionar todos=SOMA(SOMASE(C5:C12;{"A";"B"};D5:D12))

Re: Média trimestral com meses em branco

por osvaldomp ¦ 02 Set 2020 às 20:00 ¦ Fórum: Linguagem DAX/Modelagem ¦ Tópico: Média trimestral com meses em branco ¦ Respostas: 2 ¦ Exibições: 29

Se for no Excel:

Código: Selecionar todos=MÉDIA(B1:B3)

ou
Código: Selecionar todos=SOMA(B1:B3)/3

Re: SOMAR OS PRÓXIMOS DOMINGOS SUBSEQUENTES À DATA ESTIPULAD  [resolvido]

por osvaldomp ¦ 02 Set 2020 às 16:24 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Como somar datas com resultado caindo no 1º Sábado do mês? ¦ Respostas: 9 ¦ Exibições: 91

A primeira seria a de como pegar uma data inicial da COLUNA B e a partir dela descobrir os próximos 3 domingos Cole uma cópia da fórmula abaixo em C9, arraste para baixo, arraste a seleção para a direita. =$B9+7*COL(A1)-DIA.DA.SEMANA($B9)+1 E a segunda seria referente àquela SOMASE, em que me ajudo...

Em B3 e arraste:

Código: Selecionar todos=DATAM(B2;4)-DIA(DATAM(B2;4))+8-DIA.DA.SEMANA(DATAM(B2;4)-DIA(DATAM(B2;4))+1)


obs. o seu resultado em B8 está incorreto

Re: Botões anteior e próximo

por osvaldomp ¦ 01 Set 2020 às 11:48 ¦ Fórum: Macros e VBA ¦ Tópico: Botões anteior e próximo ¦ Respostas: 1 ¦ Exibições: 19

Experimente: Sub Próxima() If ActiveCell.Column <> 2 Or ActiveCell.Row >= 109 Then Exit Sub ActiveCell.Offset(1).Resize(, 22).Select End Sub Sub Anterior() If ActiveCell.Column <> 2 Or ActiveCell.Row <= 76 Then Exit Sub ActiveCell.Offset(-1).Resize(, 22).Select End Sub

Re: SOMASE COLUNAS ALTERNADAS

por osvaldomp ¦ 31 Ago 2020 às 23:19 ¦ Fórum: Fórmulas e Funções ¦ Tópico: SOMASE COLUNAS ALTERNADAS ¦ Respostas: 4 ¦ Exibições: 74

Olá. Confesso que não entendi quais cálculos você deseja fazer. Seria útil se você fizesse exatamente como fez na planilha do primeiro post, coloque cada cálculo procurado, em quais colunas estão os dados e qual o resultado esperado para cada cálculo. Você escreveu " Seriam as funções para médi...