Guru do Excel + Power BI

Sua dose diária de Power BI e Excel

Pesquisa resultou em 3444 ocorrências

 Voltar para a pesquisa avançada

Re: Apresentar mensagens conforme a data do sistema e o dia da semana

 por osvaldomp ¦  03 Out 2022 às 11:24 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Apresentar mensagens conforme a data do sistema e o dia da semana ¦  Respostas: 8 ¦  Exibições: 92

Verifique se aí também aparecem caracteres arroba "infiltrados" na fórmula, conforme em vermelho abaixo: =SEERRO(TEXTO(HOJE();"dddd dd/mm/aaaa - ")& @ ÍNDICE(A2:D16;MENOR(SE( @ C2:C16=TEXTO(HOJE();"dddd"); @ LIN(A2:A16));@LIN(1:1))-1;1)&... Se sim, então remova ...

Re: Apresentar mensagens conforme a data do sistema e o dia da semana

 por osvaldomp ¦  03 Out 2022 às 09:05 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Apresentar mensagens conforme a data do sistema e o dia da semana ¦  Respostas: 8 ¦  Exibições: 92

Inseri a fórmula na célula E1, e retornou a mensagem em branco, hoje é segunda feira, e conforme as informações deveria retornar a seguinte mensagem. Segunda-feira 03/10/2022 - Paulo Sala 2 QUIM *** Dina LAB-3 MARK *** Sandra Sala 13 TI segunda-feira 03/10/2022 - Paulo Sala 2 QUIM *** Diná Sala LAB...

Re: Apresentar mensagens conforme a data do sistema e o dia da semana

 por osvaldomp ¦  02 Out 2022 às 18:16 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Apresentar mensagens conforme a data do sistema e o dia da semana ¦  Respostas: 8 ¦  Exibições: 92

Este monstrinho deveria funcionar na versão 2016. =SEERRO(TEXTO(HOJE();"dddd dd/mm/aaaa - ")&ÍNDICE(A2:D16;MENOR(SE(C2:C16=TEXTO(HOJE();"dddd");LIN(A2:A16));LIN(1:1))-1;1)&" Sala "&ÍNDICE(A2:D16;MENOR(SE(C2:C16=TEXTO(HOJE();"dddd");LIN(A2:A16));1)-...

Re: Apresentar mensagens conforme a data do sistema e o dia da semana

 por osvaldomp ¦  01 Out 2022 às 18:45 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Apresentar mensagens conforme a data do sistema e o dia da semana ¦  Respostas: 8 ¦  Exibições: 92

Ao solicitar fórmulas, informe sempre a versão do seu Excel. Esta funciona a parir da versão 2019. =TEXTO(HOJE();"dddd dd/mm/aaaa - ")&UNIRTEXTO(" *** ";VERDADEIRO;SE(C2:C16=TEXTO(HOJE();"dddd");(A2:A16)&" Sala "&(B2:B16)&" "&(D2:...

Re: Bloquear células a partir de uma condição

 por osvaldomp ¦  27 Set 2022 às 17:38 ¦  Fórum: Macros e VBA ¦  Tópico: Bloquear células a partir de uma condição ¦  Respostas: 6 ¦  Exibições: 44

Não funciona porque o código que passei deve ser instalado no módulo da Planilha1 e não no Módulo1 . Para acessar o módulo da planilha clique com o direito na guia da Planilha1 e escolha Exibir Código . funcionamento - após preencher manualmente as colunas A, B e C, na mesma linha e em qualquer orde...

Re: Bloquear células a partir de uma condição

 por osvaldomp ¦  27 Set 2022 às 16:43 ¦  Fórum: Macros e VBA ¦  Tópico: Bloquear células a partir de uma condição ¦  Respostas: 6 ¦  Exibições: 44

nathsbd escreveu: 27 Set 2022 às 16:32 Pode me ajudar?
Podemos tentar lhe ajudar, mas para isso precisamos ver o seu arquivo com o código instalado e a explicação do que você fez na planilha e que não funcionou.

Re: Bloquear células a partir de uma condição

 por osvaldomp ¦  27 Set 2022 às 15:59 ¦  Fórum: Macros e VBA ¦  Tópico: Bloquear células a partir de uma condição ¦  Respostas: 6 ¦  Exibições: 44

Private Sub Worksheet_Change(ByVal Target As Range) If Target.Column > 3 Then Exit Sub If Application.CountA(Cells(Target.Row, 1).Resize(, 3)) < 3 Or Cells(Target.Row, 2) <> "P1" Then Exit Sub If WorksheetFunction.SumIfs(Range("C:C"), Range("A:A"), Range(Cells(Target.R...

Re: Conta giro com data.

 por osvaldomp ¦  26 Set 2022 às 16:35 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Conta giro com data. [ROSOLVIDO] ¦  Respostas: 6 ¦  Exibições: 212

Segue um "palpite" pois a sua explicação continua imprecisa.

Em C3 e arraste para baixo ~~~> =SE(B3="";"";B3-B2)

Re: Numerar coluna de acordo com o mês

 por osvaldomp ¦  23 Set 2022 às 15:57 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Numerar coluna de acordo com o mês ¦  Respostas: 2 ¦  Exibições: 47

Salve, @Jore.

Experimente ~~~> =SE(A12>=DIA(FIMMÊS(HOJE();0));"";A12+1)

Re: Validar se existe e adicionar letra ao item

 por osvaldomp ¦  21 Set 2022 às 12:15 ¦  Fórum: Macros e VBA ¦  Tópico: Validar se existe e adicionar letra ao item ¦  Respostas: 7 ¦  Exibições: 169

@osvaldomp , Funciona bem, vou estudar o código e tentar inserir as exclusões. # Salve, Jorge. Segue uma opção com Selct Case : For k = 0 To UBound(Temp) Select Case Temp(k) Case "da", "de", "do", "das", "dos", "a", "o" Case Else...

Re: Validar se existe e adicionar letra ao item

 por osvaldomp ¦  20 Set 2022 às 17:40 ¦  Fórum: Macros e VBA ¦  Tópico: Validar se existe e adicionar letra ao item ¦  Respostas: 7 ¦  Exibições: 169

Private Sub cmdGravarListaAusencias_Click() Dim Temp As Variant, k As Long, ini As String, i As Long Temp = Split(Trim(txtDesignacao_P4)) For k = 0 To UBound(Temp) ini = ini & UCase(Left(Temp(k), 1)) Next k Do Until Application.CountIf([AI:AI], ini & "*") = 0 ini = ini & Mid(T...

Uma opção é ao invés de carregar os dados diretamente na ListBox, carregá-los antes em uma matriz e depois carregar da matriz na ListBox.

Outra opção é o macete explicado neste vídeo ~~~> https://www.youtube.com/watch?v=7dNEK__40O8

Re: Erro em formula

 por osvaldomp ¦  16 Set 2022 às 16:28 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Erro em formula ¦  Respostas: 1 ¦  Exibições: 55

Sugestão: deixe as suas fórmulas por um momento, coloque manualmente o resultado esperado para cada caso e coloque as necessárias explicações de como chegou ao resultado.

Re: COUNTIFS

 por osvaldomp ¦  31 Ago 2022 às 12:23 ¦  Fórum: Fórmulas e Funções ¦  Tópico: COUNTIFS ¦  Respostas: 6 ¦  Exibições: 150

Código: Selecionar todos
=SOMARPRODUTO((A3:F3="DÉBITO")*(A$1:F$1<HOJE()))

Re: Ajuda com Macro

 por osvaldomp ¦  30 Ago 2022 às 18:59 ¦  Fórum: Macros e VBA ¦  Tópico: Ajuda com Macro ¦  Respostas: 6 ¦  Exibições: 239

Oi, Susana. Verdade. Fiz a correção. Sub ExcluiProcessosDuplicados() Application.ScreenUpdating = False Range("A4:AL" & Cells(Rows.Count, 2).End(3).Row).Sort Key1:=[O4], order1:=xlAscending, Key2:=[V4], order2:=xlAscending Range("A4:AL" & Cells(Rows.Count, 2).End(3).Row)....

Re: Dúvida na depuração

 por osvaldomp ¦  30 Ago 2022 às 15:15 ¦  Fórum: Macros e VBA ¦  Tópico: Dúvida na depuração ¦  Respostas: 1 ¦  Exibições: 123

Código: Selecionar todos
Sub teste()
 Dim x As Long
  For x = 1 To 10
   If x = 5 Then Stop
   'executa instrução
  Next x
End Sub

Re: Ajuda com Macro

 por osvaldomp ¦  30 Ago 2022 às 15:01 ¦  Fórum: Macros e VBA ¦  Tópico: Ajuda com Macro ¦  Respostas: 6 ¦  Exibições: 239

Nessas 10 linhas, 7 não possuem audiência e 3 possuem, mas com datas iguais . ... esqueci de dizer que em um mesmo processo podem aparecer duas ou mais audiências com datas diferentes. Oi, Susana. Fiz as alterações para manter os registros com datas diferentes para um mesmo Processo. Sub ExcluiProc...

Re: Ajuda com Macro

 por osvaldomp ¦  29 Ago 2022 às 19:33 ¦  Fórum: Macros e VBA ¦  Tópico: Ajuda com Macro ¦  Respostas: 6 ¦  Exibições: 239

Experimente: Sub ExcluiProcessosDuplicados() Application.ScreenUpdating = False Range("A4:AL" & Cells(Rows.Count, 2).End(3).Row).Sort Key1:=[O4], order1:=xlAscending, Key2:=[V4], order2:=xlAscending Range("A4:AL" & Cells(Rows.Count, 2).End(3).Row).RemoveDuplicates Columns...

Re: Formatação condicional

 por osvaldomp ¦  27 Ago 2022 às 17:16 ¦  Fórum: Fórmulas e Funções ¦  Tópico: Formatação condicional ¦  Respostas: 8 ¦  Exibições: 154

Ok, obrigado.

Me parece que agora estamos na mesma página.

Selecione A3:C10 e aplique esta fórmula na FC ~~~> =A$1<HOJE()

Re: Inserir linha com criterio

 por osvaldomp ¦  27 Ago 2022 às 17:04 ¦  Fórum: Macros e VBA ¦  Tópico: Inserir linha com criterio ¦  Respostas: 7 ¦  Exibições: 149

Sub InsereLinha() Dim k As Long k = Rows.Count Application.ScreenUpdating = False Do k = Cells(k, 1).End(3).Row If k = 1 Then Exit Do Rows(k).Insert: Cells(k, "I") = 0 Loop Range("I2:I" & Cells(Rows.Count, 2).End(3).Row).SpecialCells(4).FormulaR1C1 = "=SUM(R[-1]C,RC[-2]...

  • 1
  • 2
  • 3
  • 4
  • 5
  • 173
How to write a process management essay

While I didn't seek out tips for writing process m[…]

4 Tips to Offer Online Exams

Are you confused because of so many academic writi[…]

When writing an academic text, the bulk of the wor[…]

cách đây không lâu bạn c&[…]

Estou trabalhando com uma base de dados com KPI's […]

Olá Caso simples hoje Estou fazendo uma[…]

Baccarat là trò chơi dễ ăn tiền nhưn[…]