Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por AbimaelManasses 04 Dez 2019 às 15:04
Membro Novato
Mensagens: 2
Reputação: 0
#50874
Olá Pessoal, tudo bem!?

Estou com uma grande duvida, estou atualizando uma planilha que utilizamos para calculo e cotação de alguns itens... o problema se dá no momento do cálculo de área de cada item, pois se for até uns 10 itens da pra calcular na mão... mas as vezes são quase 200 itens, perde-se meio dia calculado...

A ideia é tenta deixar o mais automático possível, porem cada modelo de item demanda de uma formula diferente para calcular... por exemplo:

item1 =
Comprimento total:
(comprimento+2/3)+(largura*5)
Largura total:
(altura/2)+(largura*5)

item2 =
Comprimento total:
(altura+2/3)+(largura*5)
Largura total:
(comprimento/2)+(largura*5)

Eu preciso destes 2 dados para calcular a área total usada e assim conseguir precificar o material...
A dificuldade se da que cada linha pode ser um tipo de item (tem + de 80 modelos e cada vez é criado mais modelos) e depende do modelo para calcular com determinada formula...

Em anexo estou passando a planilha quase montada (alterei as informações com nomes genéricos, mas é daquele modelo mesmo), coloquei alguns comentários tentando deixar o mais simples possível oque eu preciso..
Se precisar posso passar mais informações...

Sei o básico de Excel, as vezes consigo fazer umas planilhas um pouco melhor, sei que existem diversos recursos incríveis no Excel mas não detenho domínio sobre eles...

Tentei buscar resposta sobre o tema, mas não consegui encontrar nada...

Espero que alguém consiga me ajudar!

Agradeço!!!

Abimael Manasses
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 04 Dez 2019 às 15:59
Membro 5 Estrelas
Mensagens: 553
Reputação: 265
#50881
Pelo que entendi, os valores de comprimento, largura e altura serão informados manualmente.
Então na aba FORMULAS MEDIDAS, tente esta em C3:
Código: Selecionar todos=SEERRO((ÍNDICE(COTAÇÃO!$D$4:$D$17;CORRESP('FORMULAS MEDIDAS'!B3;COTAÇÃO!$M$4:$M$18;0))+ÍNDICE(COTAÇÃO!$E$4:$E$17;CORRESP('FORMULAS MEDIDAS'!B3;COTAÇÃO!$M$4:$M$18;0)))*2+44;"")

E esta outra em D3:
Código: Selecionar todos=SEERRO(ÍNDICE(COTAÇÃO!$F$4:$F$17;CORRESP('FORMULAS MEDIDAS'!B3;COTAÇÃO!$M$4:$M$18;0))+6+(ÍNDICE(COTAÇÃO!$E$4:$E$17;CORRESP('FORMULAS MEDIDAS'!B3;COTAÇÃO!$M$4:$M$18;0))/2+2)*2;"")


Faça a adaptação para as outras fórmulas.

Na aba COTAÇÃO, copie o intervalo J2:K2 e cole como valores em C2:D2, na aba FORMULAS MEDIDAS.
E em seguida tente esta em J4 da aba COTAÇÃO:
Código: Selecionar todos=SEERRO(ÍNDICE('FORMULAS MEDIDAS'!$C$3:$D$100;CORRESP(COTAÇÃO!$M4;'FORMULAS MEDIDAS'!$B$3:$B$100;0);CORRESP(COTAÇÃO!J$2;'FORMULAS MEDIDAS'!$C$2:$D$2;0));"")

Copie para K4 e para baixo.

Favor conferir no anexo.

Good luck!
Apenas usuários registrados podem ver ou baixar anexos.
Por AbimaelManasses 05 Dez 2019 às 13:03
Membro Novato
Mensagens: 2
Reputação: 0
#50917
Agradeço o rápido retorno Estevaoba,

Esse código é muito útil, mas infelizmente continuou no mesmo problema que eu estava... por exemplo na primeira linha o calculo é perfeito, porem a segunda linha pode ser que tenha o mesmo modelo, caso isto aconteça ele não vai calcular este segundo modelo, mas sim utilizar das medidas do primeiro...

Nesta planilha eu terei diversos itens utilizando o mesmo modelo, a ideia era criar uma formula que funcionasse para todas as linhas mesmo com 2 modelos usando da mesma formula...

Enviei um anexo com a sua planilha, nela preenchi o modelo 100 B e já deixei meio arrumado para o erro acontecer, veja o que acontece se na célula M6 você alterar para 100 B, as medidas da linha 7 serão alterados conforme calculo feito na linha 6... O mesmo ocorre com a linha 4 e 5, veja que ambos tem medidas diferentes, mas o calculo de area está igual... apague o modelo da M4 e a linha 5 fica correta... Existe alguma forma de corrigir isto?
Apenas usuários registrados podem ver ou baixar anexos.