Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Inovacao 13 Jun 2019 às 00:04
Membro 2 Estrelas
Mensagens: 129
Reputação: 1
#44665
Bom dia, caros colegas.
Preciso da ajuda de vocês.

-Gostaria que conforme o numero de parcelas pagas da coluna E10 fosse mudando, a coluna (I)= STATUS, fosse se atualizando de forma automática e mudando os Status para PAGO e EM ABERTO.

Se alguém puder me ajudar, segue planilha.

Obrigado.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por FelipeMGarcia 13 Jun 2019 às 10:30
Excel Expert
Mensagens: 3605
Reputação: 1526
#44672
Amigo, para isso, vc vai precisar de uma coluna de data de pagamento para verificar o status, sem isso, não tem como saber quando foi feito o pagamento.

Abs
Por Inovacao 13 Jun 2019 às 11:18
Membro 2 Estrelas
Mensagens: 129
Reputação: 1
#44673
Bom dia, FelipeMGarcia.
Tudo bom?

Na verdade não é necessário nesse meu caso a data do pagamento.

Só o que preciso é o seguinte: Se a coluna E10 = 1; Apenas a parcela nº 1 fique com o esta STATUS como PAGO.

Ou se a coluna E10 = 5; Apenas as parcelas de Nº1 ATÉ A Nº5, fique com o esta STATUS como PAGO.

Etc.
Avatar do usuário
Por FelipeMGarcia 13 Jun 2019 às 12:29
Excel Expert
Mensagens: 3605
Reputação: 1526
#44674
Amigo,

Veja se o que fiz lhe ajuda, caso queira agradecer, clique na mãozinha.

Abs
Apenas usuários registrados podem ver ou baixar anexos.
Por osvaldomp 13 Jun 2019 às 12:48
Membro 5 Estrelas
Mensagens: 1198
Reputação: 595
#44676
Inovacao escreveu:Se a coluna E10 ... ~~~> E10 é referência a célula e não a coluna ;)


em I12 da planilha Rel-vencimento e arraste para baixo:
Código: Selecionar todos=SE(LINS(A$1:A1)>E$10;"em aberto";"pago")


obs. formate a coluna P da planilha Locação como Geral (não faz sentido formatar como Texto, como está atualmente e a fórmula não funcionará como desejado))
Por Inovacao 13 Jun 2019 às 14:25
Membro 2 Estrelas
Mensagens: 129
Reputação: 1
#44680
Agora deu tudo certo, porem queria tirar duas duvidas antes de finalizar, se possível responder.

-O que significa esse (*1) no final da fórmula, porque sem ele a fórmula não funciona.
=SE(G5="";0;PROCV(G5;Locação!B6:T1505;15;0))*1

-Outra coisa a fórmula PROCV, da muto erro as vezes funciona e as vezes não, tem alguma outra fórmula melhor para utilizar no lugar do PROCV?


Muito obrigado, abs!!
Avatar do usuário
Por FelipeMGarcia 13 Jun 2019 às 16:01
Excel Expert
Mensagens: 3605
Reputação: 1526
#44681
Eu multipliquei por 1 para converter o texto em número.

Abs
Por Inovacao 13 Jun 2019 às 17:47
Membro 2 Estrelas
Mensagens: 129
Reputação: 1
#44689
ok.

Eu identifiquei um erro e mesmo com varias tentativas não consegui solucionar.
Na coluna C= VENCIMENTOS só calcula os anos impares ex: 2019 ai pula para 2021, porque sera?
Por favor consegue me ajudar mais essa questão?


Obrigado.