Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por SandroLima 15 Mai 2019 às 16:09
Membro 5 Estrelas
Mensagens: 507
Reputação: 6
#43883
Boa tarde, colegas do fórum

Podem me ajudar com a fórmula do intervalo G8:R8 da Plan "HISTORICO ANUAL".

Preciso de uma fórmula que retorne a data da coluna [Disponibilidade] da TB_AtivDiarias (Plan "ATIVIDADES DIÁRIAS") referente à Fonte (Célula G7), Mês (intervalo G9:R9) e Ano (Célula C ) da Plan "HISTORICO ANUAL".

Segue Planilha anexa.
Apenas usuários registrados podem ver ou baixar anexos.
Por babdallas 15 Mai 2019 às 17:57
Membro 5 Estrelas
Mensagens: 1603
Reputação: 718
#43890
Veja se ajuda.
Apenas usuários registrados podem ver ou baixar anexos.
Por SandroLima 15 Mai 2019 às 19:49
Membro 5 Estrelas
Mensagens: 507
Reputação: 6
#43895
Quase lá, babdallas.

Não simulei uma possível situação...
Se o campo [Data} estiver vazio/em branco ("") como devo alterar a fórmula para que ela retorne vazio/também ("") também.
Atualmente se o campo data estiver vazio a fórmula
Código: Selecionar todos=SEERRO(ÍNDICE(TB_AtivDiarias[Disponibilidade];AGREGAR(15;6;(LIN(TB_AtivDiarias)-LIN(TB_AtivDiarias[#Cabeçalhos]))/((G$9=TB_AtivDiarias[Mês])*(TB_AtivDiarias[Ano]=$C$6)*(TB_AtivDiarias[Nome / Razão Social]=$G$7));1));"")

retorna 00/01/1900.

Obrigado.
Por babdallas 16 Mai 2019 às 11:11
Membro 5 Estrelas
Mensagens: 1603
Reputação: 718
#43904
Veja se resolve.

Código: Selecionar todos=SEERRO(ÍNDICE(TB_AtivDiarias[Data];AGREGAR(15;6;(LIN(TB_AtivDiarias)-LIN(TB_AtivDiarias[#Cabeçalhos]))/((TB_AtivDiarias[Disponibilidade]<>"")*(G$9=TB_AtivDiarias[Mês])*(TB_AtivDiarias[Ano]=$C$6)*(TB_AtivDiarias[Nome / Razão Social]=$G$7));1));"")