Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
#60424
Olá a todos!
Estou com uma dificuldade que é a seguinte:
Preciso descobrir o próximo número da coluna de baixo e "não o mesmo número que digitei" em uma planilha com centenas desses números aleatórios...
EX:
555
663
834
474
663
375
492
654
744
555
663
564
663

Perceba que após alimentar a planilha aqui em baixo com a centena "663" preciso descobrir QUAIS centenas DEPOIS dela de cima para baixo saíram no passado e criar uma tabela ao lado com todas centenas de forma enumadas das mais antigas para as mais atuais...
De cima para baixo:
1º 834
2º 375
3º 564
... E assim por diante...

Fórmula bem desafiadora, que poder ajudar, agradeço!

Aguardo respostas,
Obrigado
#60425
Código: Selecionar todos
=SEERRO(ÍNDICE($A$1:$A$100;MENOR(SE($A$1:$A$100=663;LIN($A$1:$A$100));LIN(Z1))+1);"")
Fórmula matricial. Cole e confirme com Ctrl+Shift+Enter em vez de Enter apenas.
Copie para baixo.
Sugiro substituir o argumento =663 por referência a uma célula contendo esse valor, por exemplo, =$B$1

Good luck!
Alex10 agradeceu por isso
#60439
Estevaoba escreveu: 11 Nov 2020 às 20:35
Código: Selecionar todos
=SEERRO(ÍNDICE($A$1:$A$100;MENOR(SE($A$1:$A$100=663;LIN($A$1:$A$100));LIN(Z1))+1);"")
Fórmula matricial. Cole e confirme com Ctrl+Shift+Enter em vez de Enter apenas.
Copie para baixo.
Sugiro substituir o argumento =663 por referência a uma célula contendo esse valor, por exemplo, =$B$1

Good luck!
Obrigado amigo pela atenção.

Coloque o número 1 em A1 e em A2 cole uma c[…]

Boa noite. Sou novo no VBA, veja se resolve o seu […]

Top, asism ficou bem melhor, Muito Obrigado

Erro em tempo de Execução...

Bom dia amigos, neste código abaixo esta da[…]

Boa tarde. Segue uma opção. At&ea[…]

Leitura de planilha fechada

Consegui explicar :) :shock: :?: :?: N&at[…]

Bom-dia! Numa pasta do servidor [ D:\Server\BemVi[…]

Enviando email outlook

Boa tarde! Estou usando o codigo abaixo e esta fun[…]