Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por gustavortoniolo 02 Dez 2019 às 15:43
Membro Novato
Mensagens: 4
Reputação: 0
#50795
Olá Pessoal! tudo bem

Estou montando uma tabela para classificar a ocorrência de um evento, é uma tabela qualitativa.. entretanto empaquei em uma parte.... eu poderia fazê-la manualmente, mas tomaria muito.. muito tempo! O que eu penso em fazer é bem simples, já tentei algumas funções mas não tive sucesso... É o seguinte: existe uma coluna que indica o ano de ocorrência do evento em um município e em outra coluna eu gostaria de "classificar", ou seja, gostaria de atribuir outro valor.... No Excel, que estou enviando em anexo, quero fazer isso na coluna M, onde já constam tais valores, mas gostaria de fazer isso de forma mais prática!

Agradecido!
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por FelipeMGarcia 02 Dez 2019 às 18:06
Excel Expert
Mensagens: 3935
Reputação: 1705
#50797
Só não entendi o critério de classificação que usou, vc poderia demonstrar?

Obrigado
Avatar do usuário
Por Estevaoba 03 Dez 2019 às 09:22
Membro 5 Estrelas
Mensagens: 553
Reputação: 265
#50806
Se puder, crie uma coluna auxiliar com esta fórmula em H2, por exemplo:

=A2&C2&D2
Copie para preencher a coluna.

E esta outra em E2:
Código: Selecionar todos=SOMARPRODUTO(--(FREQÜÊNCIA(SE(A$2:A2=A2;CORRESP(H$2:H2;H$2:H2;0));CORRESP(H$2:H2;H$2:H2;0))>0))

Copie para preencher a coluna.

Good luck!
Avatar do usuário
Por Deciog 03 Dez 2019 às 10:08
Membro 5 Estrelas
Mensagens: 1294
Reputação: 658
#50807
Estevaoba, Bom Dia.

Tudo em ordem

Muito boa logica gostei

Decio
Por gustavortoniolo 03 Dez 2019 às 11:25
Membro Novato
Mensagens: 4
Reputação: 0
#50811
Oi Pessoal, muito obrigado pela ajuda..!

FelipeMGarcia, o critério de classificação é o seguinte para o "Ano tal", atribui um "Valor tal", por exemplo, para o ano 2009 atribui o valor 5, para a série que apresentei tentei fazer de modo crescente.
Estevaoba, eu apliquei essa regra que tu disseste, mas os valores ao puxar para toda coluna se mantiveram.
Tentando resolver aqui eu fiz de outra forma bem boba, utilizando apenas a função SE, só que deu um trabalho pq tive que retirar os anos ausentes... Mais ou menos assim:

Código: Selecionar todos=SE(C10=1985;"1"; SE(C10=1986;"2"; SE(C10=1987;"3"; SE(C10=1988;"4"; SE(C10=1989;"5"; SE(C10=1990;"6"; SE(C10=1991;"7"; SE(C10=1992;"8"; SE(C10=1993;"9"; SE(C10=1994;"10"; SE(C10=1995;"11"; SE(C10=1996;"12"))))))))))))
Avatar do usuário
Por Estevaoba 03 Dez 2019 às 11:41
Membro 5 Estrelas
Mensagens: 553
Reputação: 265
#50813
Obrigado, mestre Deciog. Tudo bem sim, e você?

Gustavo, aqui a fórmula deu resultados idênticos aos seus.
Favor conferir no anexo. A fórmula está na coluna G para comparação.

Na sua fórmula com SE, seria muito melhor listar as duas matrizes e fazer busca com PROCV ou ÍNDICE & CORRESP.

Ab.
Apenas usuários registrados podem ver ou baixar anexos.
Por gustavortoniolo 04 Dez 2019 às 11:51
Membro Novato
Mensagens: 4
Reputação: 0
#50865
Muito obrigado, Estevaoba.
Sua fórmula deu super certo, expandi ela para toda planilha! Não conhecia a função somarproduto... vou pesquisar mais sobre ela!

Abraço a todos!