Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Neucir 10 Jul 2019 às 22:00
Membro Novato
Mensagens: 1
Reputação: 0
#45467
Prezad@s,

Eu sou biólogo e tenho uma planilha de ocorrência de espécies que foram amostradas em um conjunto de 5 armadilhas, dispostas em 12 pontos diferentes. Assim, eu tenho um total de 60 linhas na minha planilha. Estou com muita dificuldade de executar uma função no excel. O cenário é o seguinte:
1) quero reduzir a planilha com 60 linhas para uma com 12 linhas e para isso é quero somar os valores do número de indivíduos capturado nas armadilhas A, B, C, D e E do ponto 1, e a mesma coisa para os demais pontos. Logo estou fazendo isso em uma nova planilha, mas não consigo automatizar de forma que ao arrastar os valores sejam mostrados. O que quero é que a ação automática seja assim
célula 1: soma(ID!B2:B6); a próxima deve ser soma(ID!B7:B11) e assim por diante de 5 em 5 linhas. Não consigo automatizar isso.
2) quero contar o número de espécies dentro de um conjunto de dados, também de 5 em 5. Nesse caso eu tenho 10 especies dispostas uma em cada coluna, reunidas nas 5 armadilhas. Eu quero saber quantas espécies tenho no intervalo entre as colunas c2:L6, sem contar valores repetidos. Não consegui até agora.

Em anexo lhes envio uma planilha de modelo

Grato pela ajuda

Neucir
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Deciog 11 Jul 2019 às 10:45
Membro 5 Estrelas
Mensagens: 1181
Reputação: 591
#45476
Neucir , Bom Dia.

Conforme seu modelo

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Apenas usuários registrados podem ver ou baixar anexos.
Por osvaldomp 11 Jul 2019 às 10:50
Membro 5 Estrelas
Mensagens: 1252
Reputação: 613
#45477
Ponto 1 ~~~> cole uma cópia da fórmula abaixo em A2 e arraste para baixo
Código: Selecionar todos=SOMA(DESLOC(ID!$G$2;(LIN()-LIN($G$2))*5;;5;1))


Ponto 2 ~~~> não entendi o que você quer, coloque alguns exemplos de resultados esperados
Por babdallas 11 Jul 2019 às 11:24
Membro 5 Estrelas
Mensagens: 1749
Reputação: 778
#45478
Veja se ajuda.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por FelipeMGarcia 11 Jul 2019 às 13:29
Excel Expert
Mensagens: 3697
Reputação: 1578
#45483
Neucir, segue fórmula para contar os itens únicos do intervalo de 5 em 5 linhas:

=SOMARPRODUTO(--(FREQÜÊNCIA(INDIRETO("ID!g"&(LIN()-2)*5+2&":AL"&(LIN()-1)*5+1);INDIRETO("ID!g"&(LIN()-2)*5+2&":AL"&(LIN()-1)*5+1))>0))

Caso queira agradecer, clique na mãozinha, com relação a sua dúvida de somar dentro do intervalo, não vou responder, pois usaria a mesma fórmula do amigo Osvaldo.

Abs