Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por marciomorel 15 Mai 2019 às 18:55
Membro Novato
Mensagens: 6
Reputação: 0
#43892
Se alguem puder me ajudar agradeco muito.
É o seguinte:

tenho uma tabela onde tenho 2 colunas : a e b

A B
1 xyz
1 uio
1 hkl
2 xxx
2 opo
2 yyy
2 zzz

tenho outra panilha onde em uma celula (z1) quero uma lista de validacao onde apareçam apenas os dados de a=1 ou a=2 dependendo do valor de outra celula(y2) 1 ou 2.

Como executar isso?

Obrigado.
Avatar do usuário
Por Estevaoba 16 Mai 2019 às 01:29
Membro 5 Estrelas
Mensagens: 415
Reputação: 187
#43898
Criei uma coluna auxiliar AB para listar os itens referentes ao valor em Y2 com esta fórmula matricial:
Código: Selecionar todosAB1=SEERRO(ÍNDICE($B$1:$B$100;MENOR(SE($A$1:$A$100=$Y$2;LIN($A$1:$A$100));LIN(A1)));0)

Ao editar esta fórmula matricial, confirme com Ctrl+Shift+Enter.
E copie para preencher a coluna.

Depois criei um intervalo dinâmico nomeado Lista com esta fórmula:
Código: Selecionar todos=DESLOC(Planilha1!$AB$1;;;CONT.VALORES(Planilha1!$AB$1:$AB$100)-CONT.SE(Planilha1!$AB$1:$AB$100;0);1)


E na validação de dados em Z1, no campo Fonte:
=Lista

Confira no anexo e veja se atende.
Ajuste os intervalos conforme sua necessidade.

Good luck!
Apenas usuários registrados podem ver ou baixar anexos.