Utilize essa sessão para postar e solucionar desafios de Excel, matemáticos, lógicos, etc...
Avatar do usuário
Por JairJunior2 22 Mai 2019 às 10:45
Membro 1 Estrela
Mensagens: 28
Reputação: 3
#44075
Bom dia!

Estou com um problema em uma planilha e preciso de ajuda.

Preciso que esta planilha intenda e some as quatro células a direta, diferente de 0 ou vazio e que caso não haja 4 células some somente as 3, 2 ou 1 de células.

Segue em anexo o arquivo.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Deciog 22 Mai 2019 às 12:45
Membro 5 Estrelas
Mensagens: 1216
Reputação: 609
#44080
JairJunior2, Bom Dia.

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Apenas usuários registrados podem ver ou baixar anexos.
Por osvaldomp 22 Mai 2019 às 16:41
Membro 5 Estrelas
Mensagens: 1310
Reputação: 649
#44094
Experimente uma cópia da fórmula abaixo em M3 e arraste para baixo.

Código: Selecionar todos=SE(CONT.SE(A3:L3;">"&0)<5;SOMA(A3:L3);SOMA(DESLOC(A3;;CONT.SE(A3:L3;">"&0)-4;;4)))
Avatar do usuário
Por JairJunior2 24 Mai 2019 às 23:23
Membro 1 Estrela
Mensagens: 28
Reputação: 3
#44173
Deciog escreveu:JairJunior2, Bom Dia.

Confere se é desta forma que desejas

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio


Boa Noite Décio!

A fórmula aqui, retornou erro... só abri a planilha e apareceu o erro. Não consegui adicionar uma imagem do erro em anexo a mensagem ai coloquei no arquivo em anexo.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por JairJunior2 24 Mai 2019 às 23:29
Membro 1 Estrela
Mensagens: 28
Reputação: 3
#44174
osvaldomp escreveu:Experimente uma cópia da fórmula abaixo em M3 e arraste para baixo.

Código: Selecionar todos=SE(CONT.SE(A3:L3;">"&0)<5;SOMA(A3:L3);SOMA(DESLOC(A3;;CONT.SE(A3:L3;">"&0)-4;;4)))



Obrigado Osvaldo!

Era isso mesmo que precisava. Show de Bola! :D
Avatar do usuário
Por Deciog 25 Mai 2019 às 10:08
Membro 5 Estrelas
Mensagens: 1216
Reputação: 609
#44183
JairJunior2, Bom Dia.


Provavelmente o seu Excel é uma versão anterior a de 2013 por isso a formula não funcionou, mas a solução do colega osvaldomp é menor e ótima e funciona na sua versão

Decio