Assuntos que não estiverem relacionados as categorias acima. Se não souber em qual categoria sua mensagem se encaixa, envie aqui.
Avatar do usuário
Por SILVIOGUIMARAES 22 Nov 2019 às 23:15
Membro Novato
Mensagens: 5
Reputação: 0
#50537
Em uma planilha em Excell, tenho várias pastas. Na primeira delas, descrevo despesas colocadas em colunas nos respectivos meses para pagar:

DIA DESCRIÇÃO------------------- NOV----- DEZ------JAN----FEV
1 Aluguel do imóvel---------------------800,00------------780,00
1 Conta de água--------------160,00
2 Boleto Rafas Armarinho-------------136,00
5 Boleto Junior Lima--------600,00-----------------------430,00
9 Depositar conta filha-----400,00---200,00
17 Gasto X----------------------------------100,00

Preciso, em outra pasta por exemplo, chamada NOV, descrever somente os gastos com valores previstos para este mês.

DIA DESCRIÇÃO NOV
1 Conta de água-----------160,00
5 Boleto Junior Lima-----600,00
9 Depositar conta filha--400,00

Poderiam me auxiliar?
Como sou novo no grupo, devo ter enviado esta pergunta também junto com a apresentação para o grupo, o que antecipadamente peço desculpas.
Avatar do usuário
Por Deciog 23 Nov 2019 às 10:02
Membro 5 Estrelas
Mensagens: 1294
Reputação: 658
#50541
O ideal é postar um modelo para que possamos fazer a formula

Decio
Avatar do usuário
Por SILVIOGUIMARAES 26 Nov 2019 às 23:37
Membro Novato
Mensagens: 5
Reputação: 0
#50661
SILVIOGUIMARAES escreveu:Em uma planilha em Excell, tenho várias pastas. Na primeira delas, descrevo despesas colocadas em colunas nos respectivos meses para pagar:

DIA DESCRIÇÃO------------------- NOV----- DEZ------JAN----FEV
1 Aluguel do imóvel---------------------800,00------------780,00
1 Conta de água--------------160,00
2 Boleto Rafas Armarinho-------------136,00
5 Boleto Junior Lima--------600,00-----------------------430,00
9 Depositar conta filha-----400,00---200,00
17 Gasto X----------------------------------100,00

Preciso, em outra pasta por exemplo, chamada NOV, descrever somente os gastos com valores previstos para este mês.

DIA DESCRIÇÃO NOV
1 Conta de água-----------160,00
5 Boleto Junior Lima-----600,00
9 Depositar conta filha--400,00

Poderiam me auxiliar?
Como sou novo no grupo, devo ter enviado esta pergunta também junto com a apresentação para o grupo, o que antecipadamente peço desculpas.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 27 Nov 2019 às 01:06
Membro 5 Estrelas
Mensagens: 557
Reputação: 266
#50663
Fórmula matricial. Cole em A2 de uma planilha de mês e confirme com Ctrl+Shift+Enter.

Código: Selecionar todos=SEERRO(ÍNDICE('GASTOS PREVISTOS'!$A$2:$D$10;MENOR(SE(ÉNÚM(DESLOC('GASTOS PREVISTOS'!$A$2;;CORRESP(DIREITA(@CÉL("nome.arquivo";$Z$1); NÚM.CARACT(@CÉL("nome.arquivo"; $Z$1))- LOCALIZAR("]";@CÉL("nome.arquivo";$Z$1)));'GASTOS PREVISTOS'!$B$1:$N$1;0);100;1));LIN('GASTOS PREVISTOS'!$A$2:$A$10)-1);LIN($Z1));CORRESP(A$1;'GASTOS PREVISTOS'!$A$1:$N$1;0));"")

Copie para a direita e para baixo.

A fórmula se baseia no padrão do modelo:
Aba de mês e sua coluna de mês com o mesmo nome do respectivo mês na aba GASTOS PREVISTOS.

Good luck!
Avatar do usuário
Por Deciog 27 Nov 2019 às 08:34
Membro 5 Estrelas
Mensagens: 1294
Reputação: 658
#50664
SILVIOGUIMARAES, Bom Dia.

Outra forma de fazer confere

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por SILVIOGUIMARAES 27 Nov 2019 às 21:18
Membro Novato
Mensagens: 5
Reputação: 0
#50692
Estevaoba escreveu:Fórmula matricial. Cole em A2 de uma planilha de mês e confirme com Ctrl+Shift+Enter.

Código: Selecionar todos=SEERRO(ÍNDICE('GASTOS PREVISTOS'!$A$2:$D$10;MENOR(SE(ÉNÚM(DESLOC('GASTOS PREVISTOS'!$A$2;;CORRESP(DIREITA(@CÉL("nome.arquivo";$Z$1); NÚM.CARACT(@CÉL("nome.arquivo"; $Z$1))- LOCALIZAR("]";@CÉL("nome.arquivo";$Z$1)));'GASTOS PREVISTOS'!$B$1:$N$1;0);100;1));LIN('GASTOS PREVISTOS'!$A$2:$A$10)-1);LIN($Z1));CORRESP(A$1;'GASTOS PREVISTOS'!$A$1:$N$1;0));"")

Copie para a direita e para baixo.

A fórmula se baseia no padrão do modelo:
Aba de mês e sua coluna de mês com o mesmo nome do respectivo mês na aba GASTOS PREVISTOS.

Good luck!



Eu consegui no mês específico mas somente na primeira linha. As demais, mesmo copiando a fórmula as linhas ficaram em branco.
Avatar do usuário
Por SILVIOGUIMARAES 27 Nov 2019 às 21:45
Membro Novato
Mensagens: 5
Reputação: 0
#50693
Deciog escreveu:SILVIOGUIMARAES, Bom Dia.

Outra forma de fazer confere

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio


Tudo bem? Na sua planilha os dados DIA e DESCRIÇÃO teriam que ser fixos em todos os meses, e o que quero é, em determinado mês, exibir o DIA, DESCRIÇÃO e VALOR somente dos itens listados na planilha GASTOS PREVISTOS referentes áquele mês.
Avatar do usuário
Por Estevaoba 27 Nov 2019 às 21:54
Membro 5 Estrelas
Mensagens: 557
Reputação: 266
#50694
É uma fórmula matricial.
Para funcionar corretamente e pra todas as linhas precisa que pressione
simultaneamente Ctrl, Shift e Enter.
Quando fizer corretamente vão aparecer chaves { } cercando a fórmula na barra
de fórmulas.

Ab.