Assuntos que não estiverem relacionados as categorias acima. Se não souber em qual categoria sua mensagem se encaixa, envie aqui.
Por Nadh 08 Jul 2019 às 23:30
Membro Novato
Mensagens: 3
Reputação: 0
#45417
Boa noite, preciso de uma ajuda. É o seguinte tenho numa mesma planilha duas colunas de nome CÓDIGO e duas colunas de nome QUANTIDADE, sendo que uma se refere ao estoque A e outra ao estoque B.

Preciso criar apenas uma coluna de códigos e que as suas quantidades sejam somadas. Porém tem codigos no estoque A que nao tem no estoque B e vice versa.
Não sei se ficou de facil entendimento, mas caso não entendam só perguntar que tento ser mais clara.
Desde já obrigada.
Att
Avatar do usuário
Por Deciog 09 Jul 2019 às 10:02
Membro 5 Estrelas
Mensagens: 1277
Reputação: 646
#45421
Nadh , Bom Dia.

Poste um modelo com dados fictícios,mas, na mesma estrutura para que possamos fazer a formula correta

Decio
Por Nadh 09 Jul 2019 às 23:42
Membro Novato
Mensagens: 3
Reputação: 0
#45437
Boa noite Decio,

Segue a planilha, lembrando que são os mesmos produtos porem em estoques diferentes com quantidade diferentes. A coluna SOMATORIO que criei seria o resultado final.

Obrigada desde já.

Nádhina
Apenas usuários registrados podem ver ou baixar anexos.
Por osvaldomp 10 Jul 2019 às 11:26
Membro 5 Estrelas
Mensagens: 1406
Reputação: 696
#45443
Segue uma ideia.

1. copie de A3:A1114 e cole em G3
2. copie de B3:B1114 e cole em G1115
3. selecione de G3 até o último número nessa coluna
4. menu Dados / Remover Duplicatas / Continuar com a seleção / desmarque Meus dados contêm / OK / OK
5. mantenha a seleção e classifique de A para Z
6. em H3 cole uma cópia da fórmula abaixo e dê duplo clique no canto inferior direito para estender a fórmula para baixo
Código: Selecionar todos=SEERRO(ÍNDICE($B$3:$B$1114;CORRESP(G3;$A$3:$A$1114;0));0)+SEERRO(ÍNDICE($E$3:$E$1114;CORRESP(G3;$D$3:$D$1114;0));0)


Se essa "ordenação" for efetuada frequentemente, então para abreviar o trabalho manual e o tempo empregado, ela poderá ser efetuada via macro, se você tiver interesse.