Pesquisa resultou em 1174 ocorrências

Voltar à pesquisa avançada

Experimente:

Código: Selecionar todosSub DeletaRetângulos()
 Dim shp As Shape
  For Each shp In ActiveSheet.Shapes
   If Left(shp.Name, 9) = "Rectangle" Then shp.Delete
  Next shp
End Sub

Re: Rotatividade diária dos nomes  [resolvido]

por osvaldomp ¦ 22 Mai 2019 às 17:48 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Rotatividade diária dos nomes ¦ Respostas: 4 ¦ Exibições: 45

Olá, Geneci.

Veja se a fórmula abaixo atende.

Código: Selecionar todos=ÍNDICE(A1:A50;MOD(HOJE()-"22/05/2019";CONT.VALORES(A1:A50))+1)

Re: Somar Intervalos Variáveis

por osvaldomp ¦ 22 Mai 2019 às 16:41 ¦ Fórum: Desafios ¦ Tópico: Somar Intervalos Variáveis ¦ Respostas: 2 ¦ Exibições: 26

Experimente uma cópia da fórmula abaixo em M3 e arraste para baixo.

Código: Selecionar todos=SE(CONT.SE(A3:L3;">"&0)<5;SOMA(A3:L3);SOMA(DESLOC(A3;;CONT.SE(A3:L3;">"&0)-4;;4)))

Re: Lista Suspensa  [resolvido]

por osvaldomp ¦ 21 Mai 2019 às 17:32 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Lista Suspensa ¦ Respostas: 3 ¦ Exibições: 20

Na Validação de Dados daquelas células utilize Intervalo Dinâmico Nomeado.

https://www.guiadoexcel.com.br/lista-de-dados-com-tamanho-dinamico-excel/

Re: Formatar botão de conttole  [resolvido]

por osvaldomp ¦ 20 Mai 2019 às 10:28 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Formatar botão de conttole ¦ Respostas: 10 ¦ Exibições: 47

menu Fórmulas / Gerenciador de Nomes / Novo / na caixa Nome: insira ~~~>Fornecedor1 e na caixa Refere-se a: insira uma cópia da fórmula que passei antes / OK / Fechar

Re: Formatar botão de conttole  [resolvido]

por osvaldomp ¦ 19 Mai 2019 às 23:38 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Formatar botão de conttole ¦ Respostas: 10 ¦ Exibições: 47

Segue o arquivo com o recurso que comentei.


obs. aproveite para corrigir o título deste tópíco, pois não se trata de FORMATAR BOTÃO DE CONTTOLE

Re: Contador de horas  [resolvido]

por osvaldomp ¦ 19 Mai 2019 às 13:31 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Contador de horas ¦ Respostas: 4 ¦ Exibições: 39

Experimente uma cópia da fórmula abaixo em G1.
Formate G1 como Personalizado / [h]:mm

Código: Selecionar todos=PROC(2;1/(B2:B11=I1);D2:D12)-PROC(2;1/(B2:B11=I1);D1:D10)

Re: [Dúvida] Arredondar para múltiplo  [resolvido]

por osvaldomp ¦ 19 Mai 2019 às 01:47 ¦ Fórum: Excel Básico ¦ Tópico: [Dúvida] Arredondar para múltiplo ¦ Respostas: 1 ¦ Exibições: 18

Código: Selecionar todos=ARREDMULTB(A1;4)

Re: [Dúvida] Operação condicional  [resolvido]

por osvaldomp ¦ 19 Mai 2019 às 01:41 ¦ Fórum: Excel Básico ¦ Tópico: [Dúvida] Operação condicional ¦ Respostas: 1 ¦ Exibições: 16

Código: Selecionar todos=(A1-6)*(A1>6)

Re: Formatar botão de conttole  [resolvido]

por osvaldomp ¦ 19 Mai 2019 às 01:01 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Formatar botão de conttole ¦ Respostas: 10 ¦ Exibições: 47

1. como o @Patropi sugeriu, crie um Intervalo Dinâmico Nomeado, nome Fornecedor1 , e no campo Refere-se a: cole uma cópia da fórmula abaixo. =DESLOC(Fornecedores!$B$2;0;0;CONT.VALORES(Fornecedores!$B:$B)-1;1) 2. em seguida clique com o direito na Caixa de Combinação / Formatar controle / Controle / ...

Experimente:

Código: Selecionar todos=SOMARPRODUTO(CONT.SE(B3:U4;AA7:AJ16))

Re: FORMULA SOMASES

por osvaldomp ¦ 16 Mai 2019 às 16:32 ¦ Fórum: Fórmulas e Funções ¦ Tópico: FORMULA SOMASES ¦ Respostas: 2 ¦ Exibições: 25

Experimente remover as aspas da sua fórmula (em vermelho abaixo).
=IFS(C2<98;"1"; C2<215;"3")

Re: Busca Informação  [resolvido]

por osvaldomp ¦ 16 Mai 2019 às 16:23 ¦ Fórum: Macros e VBA ¦ Tópico: Busca Informação ¦ Respostas: 2 ¦ Exibições: 30

Dim W As Worksheet, i As Long, l As Long Set W = Sheets("Rodeio") i = W.Range("D" & Rows.Count).End(xlUp).Row 'última linha com conteúdo na coluna D For l = 3 To i If CDbl(Entidade.Text) = W.Cells(l, 16) Then textbox1.Text = W.Cells(l, 17) textbox2.Text = W.Cells(l, 18) text...

Olá, Geneci.

Veja se ajuda.

substitua esta linha

Código: Selecionar todosRange("A1:I25").Select

por esta
Código: Selecionar todosRange("A1:I" & ActiveSheet.UsedRange.Rows.Count).Select

Re: Erro estranho na definição de variáveis

por osvaldomp ¦ 14 Mai 2019 às 21:09 ¦ Fórum: Macros e VBA ¦ Tópico: Erro estranho na definição de variáveis ¦ Respostas: 1 ¦ Exibições: 24

É preciso reiniciar a captação do erro.

Acrescente a linha em vermelho conforme abaixo.

i = i - 1
Resume
GoTo Search

Re: Botão adicionar valor a uma célula  [resolvido]

por osvaldomp ¦ 13 Mai 2019 às 09:45 ¦ Fórum: Macros e VBA ¦ Tópico: Botão adicionar valor a uma célula ¦ Respostas: 2 ¦ Exibições: 32

Experimente:

Código: Selecionar todosSub AdicionaDescarga()
 Dim r As Long
  r = [H3:H7].Find([E13]).Row
  Cells(r, 9) = Cells(r, 9) + [F13]
End Sub

Re: Excel VBA Aviso

por osvaldomp ¦ 09 Mai 2019 às 16:00 ¦ Fórum: Macros e VBA ¦ Tópico: Excel VBA Aviso ¦ Respostas: 3 ¦ Exibições: 63

MrLyma escreveu:... mais acho que não soube eu me expressar direito e o código que o Sr escreveu não atenderia.


E o senhor poderia nos informar a razão pela qual o senhor acha que o código que eu sugeri não atenderia ?

O senhor ao menos fez testes ?

Re: Excel VBA Aviso

por osvaldomp ¦ 09 Mai 2019 às 11:27 ¦ Fórum: Macros e VBA ¦ Tópico: Excel VBA Aviso ¦ Respostas: 3 ¦ Exibições: 63

Experimente Dim i As Long For i = 2 To 71 With formulario_menu If Sheets("Recados").Range("B" & i) <> "" Then .Controls("cmd_ap" & i + 9).BackColor = &H808080 .Controls("cmd_ap" & i + 9).ForeColor = &HFFFFFF Else .Controls("c...

Re: Somar os máximos entre duas colunas  [resolvido]

por osvaldomp ¦ 06 Mai 2019 às 19:28 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Somar os máximos entre duas colunas ¦ Respostas: 2 ¦ Exibições: 68

Experimente:

matricial

Código: Selecionar todos=SOMA(SE(A1:A10>B1:B10;A1:A10;B1:B10))


ou
Código: Selecionar todos=SOMARPRODUTO(SUBTOTAL(4;DESLOC(A1:B1;LIN(B1:B10)-LIN(A1);0;)))

Re: Saber o dia da folga a cada 15 dias.  [resolvido]

por osvaldomp ¦ 05 Mai 2019 às 12:32 ¦ Fórum: Macros e VBA ¦ Tópico: Saber o dia da folga a cada 15 dias. ¦ Respostas: 1 ¦ Exibições: 76

Olá, Geneci.

Veja se a fórmula abaixo atende.

Código: Selecionar todos=SE(OU(DIA.DA.SEMANA(A3)=5;E(DIA.DA.SEMANA(A3)=1;ÉPAR((A3-A2)/7)));"folga";"trabalho")