Pesquisa resultou em 1242 ocorrências

Voltar à pesquisa avançada

Re: Índice de abas e outras informações

por osvaldomp ¦ 16 Jul 2019 às 13:27 ¦ Fórum: Macros e VBA ¦ Tópico: Índice de abas e outras informações ¦ Respostas: 3 ¦ Exibições: 22

Se você quiser testar uma solução via macro, instale uma cópia do código abaixo em um módulo comum, assim: 1. copie o código daqui 2. a partir de qualquer planilha tecle 'Alt+F11' para acessar o editor de VBA 3. no menu do editor / Inserir / Módulo 4. cole o código na janela em branco que vai se abr...

Re: Validação de dados

por osvaldomp ¦ 16 Jul 2019 às 13:03 ¦ Fórum: Macros e VBA ¦ Tópico: Validação de dados ¦ Respostas: 7 ¦ Exibições: 72

Sub InsereTexto() Dim LR As Long, b As Range Application.ScreenUpdating = False ActiveSheet.AutoFilterMode = False LR = Cells(Rows.Count, 2).End(3).Row For Each b In Range("B2:B" & LR).SpecialCells(2) [D1:G1].AutoFilter 1, b.Offset(, -1).Value [D1:G1].AutoFilter 2, b.Value [D1:G1].Aut...

Re: Barras de Dados em Formatação Condicional

por osvaldomp ¦ 16 Jul 2019 às 12:42 ¦ Fórum: Tabelas Dinâmicas e Recursos Diversos ¦ Tópico: Barras de Dados em Formatação Condicional ¦ Respostas: 1 ¦ Exibições: 16

Na versão Excel 2010 não é possível formatar com mais de uma cor. Não sei em versões mais recentes. Como alternativa a formatação abaixo irá mostrar uma barra de cor única, sólida ou gradual, com base nos valores mínimo e máximo da célula, na coluna C. Selecione C2 e aplique a formatação com as fórm...

Re: * Formula VBA para separar números aleatórios  [resolvido]

por osvaldomp ¦ 15 Jul 2019 às 13:28 ¦ Fórum: Fórmulas e Funções ¦ Tópico: * Formula VBA para separar números aleatórios ¦ Respostas: 2 ¦ Exibições: 34

Experimente o código abaixo. Sub ReplicaNúmeros() Dim nArr(1 To 100), c As Range, i As Long For Each c In [F3:O12] If c.Interior.ColorIndex = 14 Then nArr(i + 1) = c.Value: i = i + 1 Next c [F15].Resize(, i + 1) = nArr End Sub obs. com pequenas alterações no código acima é possível resolver também a...

Re: Localizar de acordo com o horário  [resolvido]

por osvaldomp ¦ 14 Jul 2019 às 18:39 ¦ Fórum: Macros e VBA ¦ Tópico: Localizar de acordo com o horário ¦ Respostas: 3 ¦ Exibições: 60

Olá, Geneci. Veja se atende. Cole uma cópia dos três códigos abaixo no módulo da Plan1 e em qualquer célula vazia coloque =A1 . funcionamento - os valores em D1:F1 serão atualizados pelos códigos após a alteração manual do nome em C1 ou após a mudança da hora em A1, manualmente ou via código MeuRelo...

Re: Converter e separar por datas

por osvaldomp ¦ 14 Jul 2019 às 12:33 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Converter e separar por datas ¦ Respostas: 2 ¦ Exibições: 48

Preciso criar uma macro para converter . (ponto) em , (virgula) dos números das colunas B e C. obs. 1. não foi possível testar a operação acima com o código pois na planilha sensor (5) não há pontos. 2. antes de testar o código limpe a planilha 08-07-2019 3. antes de testar o código formate as colu...

Re: Manipulação de Tabela VBA - Userform

por osvaldomp ¦ 12 Jul 2019 às 22:54 ¦ Fórum: Macros e VBA ¦ Tópico: Manipulação de Tabela VBA - Userform ¦ Respostas: 1 ¦ Exibições: 46

Experimente: Private Sub CommandButton2_Click() Dim Tabela As ListObject, Nova_Linha As Long Set Tabela = Planilha11.ListObjects("Registro") Nova_Linha = Cells(Rows.Count, Tabela.Range.Cells(1, 1).Column).End(3).Row Tabela.Range(Nova_Linha, 1).Value = ComboBox1.Text Tabela.Range(Nova_Linha...

Re: mutilas funções de uma celular ?

por osvaldomp ¦ 11 Jul 2019 às 15:24 ¦ Fórum: Excel Básico ¦ Tópico: mutilas funções de uma celular ? ¦ Respostas: 2 ¦ Exibições: 67

Veja o exemplo no arquivo anexado se pode ser um ponto de partida.

Ponto 1 ~~~> cole uma cópia da fórmula abaixo em A2 e arraste para baixo

Código: Selecionar todos=SOMA(DESLOC(ID!$G$2;(LIN()-LIN($G$2))*5;;5;1))


Ponto 2 ~~~> não entendi o que você quer, coloque alguns exemplos de resultados esperados

Re: Lista de nomes  [resolvido]

por osvaldomp ¦ 10 Jul 2019 às 19:02 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Lista de nomes ¦ Respostas: 1 ¦ Exibições: 58

opção1 - por fórmula na coluna B em B1 cole uma cópia desta fórmula e arraste para baixo ~~~> =SE(A1="";"";SE(CONT.SE($J$1:$J$10;A1);"hummm...";"ok")) opção2 - por Formatação Condicional na coluna A selecione o intervalo de uso na coluna A, por exemplo A1:A100...

Re: Criar planilhas, copiar e manter formatação

por osvaldomp ¦ 10 Jul 2019 às 11:55 ¦ Fórum: Macros e VBA ¦ Tópico: Criar planilhas, copiar e manter formatação ¦ Respostas: 2 ¦ Exibições: 52

Sugestão: deixe de lado o seu código e disponibilize uma amostra do seu arquivo Excel com a planilha base (a tal que você quer "dividir") e com mais duas planilhas como exemplos, com conteúdos e formatos exatamente como você pretende que fiquem as planilhas a serem geradas.

Re: Ordenar uma coluna conforme outra coluna

por osvaldomp ¦ 10 Jul 2019 às 11:26 ¦ Fórum: Outros Assuntos ¦ Tópico: Ordenar uma coluna conforme outra coluna ¦ Respostas: 3 ¦ Exibições: 108

Segue uma ideia. 1. copie de A3:A1114 e cole em G3 2. copie de B3:B1114 e cole em G1115 3. selecione de G3 até o último número nessa coluna 4. menu Dados / Remover Duplicatas / Continuar com a seleção / desmarque Meus dados contêm / OK / OK 5. mantenha a seleção e classifique de A para Z 6. em H3 co...

Re: comparar 3 colunas no excel

por osvaldomp ¦ 10 Jul 2019 às 10:09 ¦ Fórum: Fórmulas e Funções ¦ Tópico: comparar 3 colunas no excel ¦ Respostas: 3 ¦ Exibições: 70

Código: Selecionar todos=SE(E(A1=B1;B1=C1);"ok";"analisar")  ou
=SE(CONT.SE(A1:C1;A1)=3;"ok";"analisar")

Re: Sequência numérica - ímpares /pares

por osvaldomp ¦ 09 Jul 2019 às 19:11 ¦ Fórum: Excel Básico ¦ Tópico: Sequência numérica - ímpares /pares ¦ Respostas: 2 ¦ Exibições: 64

Cole uma cópia da fórmula abaixo em A2, arraste até D2 e em seguida arraste a seleção até a linha 6.

Código: Selecionar todos=DIREITA(A1+2;1)

Re: Bloquear Movimento das Guias

por osvaldomp ¦ 09 Jul 2019 às 16:16 ¦ Fórum: Excel Básico ¦ Tópico: Bloquear Movimento das Guias ¦ Respostas: 1 ¦ Exibições: 43

Experimente:

menu Revisão / Proteger Pasta de Trabalho / marque Estrutura

Re: Inserção de Linhas em uma Planilha Protegida

por osvaldomp ¦ 09 Jul 2019 às 13:16 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Inserção de Linhas em uma Planilha Protegida ¦ Respostas: 4 ¦ Exibições: 97

... mas a minha necessidade é de poder arrastar a última linha da tabela para inserir uma nova linha na tabela. Entendi. Me parece que trata-se de Tabela Excel . Uma alternativa é, com a planilha ainda desprotegida, expandir a Tabela deixando algumas linhas vazias e aí proteger a planilha. Terá que...

Copiar e copiar em varias linhas

por osvaldomp ¦ 09 Jul 2019 às 10:47 ¦ Fórum: Macros e VBA ¦ Tópico: Copiar e copiar em varias linhas ¦ Respostas: 1 ¦ Exibições: 49

Sugestão: disponibilize uma amostra do seu arquivo Excel com alguns exemplos, com o resultado desejado e informe em que momento você quer rodar a macro.

Re: Inserção de Linhas em uma Planilha Protegida

por osvaldomp ¦ 09 Jul 2019 às 10:43 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Inserção de Linhas em uma Planilha Protegida ¦ Respostas: 4 ¦ Exibições: 97

Já experimentou marcar a opção Inserir linhas ao proteger a planilha ?

Olá, Geneci. Experimente uma cópia do código abaixo no módulo da planilha. Private Sub Worksheet_Change(ByVal Target As Range) Dim n As Range If Target.Count > 1 Then Exit Sub If Target.Address <> "$M$1" Or Target.Value = "" Then Exit Sub Set n = [A7:J10].Find([M1], lookat:=xlWho...

Re: PROBLEMA EXCEL - DESAFIO RASTREIO

por osvaldomp ¦ 06 Jul 2019 às 16:36 ¦ Fórum: Fórmulas e Funções ¦ Tópico: PROBLEMA EXCEL - DESAFIO RASTREIO ¦ Respostas: 1 ¦ Exibições: 60

Experimente:

Código: Selecionar todos=CONT.SE(B2:B7;"*teste*")

Código: Selecionar todos=SOMASE(B2:B7;"*teste*";C2:C7)